#silverstripe IRC Log

IRC log for 25 March 2017

All timestamps are in UTC.

1: [00:10:18] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
2: [00:57:22] * filisko quit (Ping timeout: 264 seconds)
3: [09:12:30] * Shrike_Finland has joined #silverstripe
4: [10:05:49] * gelignite has joined #silverstripe
5: [10:55:43] * filisko has joined #silverstripe
6: [12:43:07] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
7: [13:10:02] * Azure quit (Ping timeout: 258 seconds)
8: [13:20:49] * Azure has joined #silverstripe
9: [13:25:10] * Azure quit (Ping timeout: 240 seconds)
10: [13:26:15] * Azure has joined #silverstripe
11: [13:32:59] * Azure quit (Ping timeout: 268 seconds)
12: [13:35:06] * Azure has joined #silverstripe
13: [14:03:18] * Mathew has joined #silverstripe
14: [14:07:31] <Mathew> Hi all. I'm having a bit of an issue with a template file not being found
15: [14:08:24] <Mathew> It works perfectly on my own set up (XAMPP), but when it's live, it can't find the file (which *does* exist). The file is an included file (/themes/theme-name/Includes/CallBar.ss), but it's just not finding it :(
16: [14:09:06] <Mathew> Any suggestions on how to debug this please?
17: [14:09:59] <Zauberfisch> did you flush?
18: [14:10:08] <Mathew> Many times
19: [14:11:05] <Zauberfisch> (also in the frontend, depending on your ss version it might not flush template cache if you do it on /dev/build only
20: [14:11:06] <Zauberfisch> )
21: [14:12:26] <Mathew> Hmm... Error 500. Nothing in the logs though
22: [14:14:37] <Zauberfisch> turn on error reporting and display errors?
23: [14:14:51] <Mathew> I've set it to on in the _config.php file
24: [14:14:53] <Zauberfisch> (also note that there is a bug in SSViwer that empty templates might break your website
25: [14:15:12] <Zauberfisch> setting display_errors or error_reporting doesn't work in _config.php in 3.x
26: [14:15:23] <Mathew> Ah, OK. That may be why then
27: [14:15:31] <Zauberfisch> that happens during the error control chain thingy which overwrites it
28: [14:15:57] <Zauberfisch> so either do it in php.ini, .htaccess, _ss_environment.php or index.php
29: [14:16:20] <Zauberfisch> (you might not use all or any of those configuration files though)
30: [14:19:39] <Mathew> Ah ha! Thanks :)
31: [14:20:48] <Mathew> Perfect! All working
32: [14:44:14] * Mathew quit (Ping timeout: 260 seconds)
33: [16:41:09] * UndefinedOffset has joined #silverstripe
34: [17:44:59] * gelignite has joined #silverstripe
35: [19:15:24] <ss-helper> .htaccess mod_rewrite, remove first segment in some cases (when it is a country code) - http://stackoverflow.com/questions/43020744/htaccess-mod-rewrite-remove-first-segment-in-some-cases-when-it-is-a-country
36: [21:06:42] * UndefinedOffset quit (Quit: Leaving.)
37: [21:25:34] * guci0 quit (Ping timeout: 260 seconds)
38: [21:50:17] * Shrike_Finland quit (Quit: Leaving.)
39: [23:00:01] * ss-helper quit (Remote host closed the connection)
40: [23:00:16] * ss-helper has joined #silverstripe
41: [23:09:14] * filisko quit (Remote host closed the connection)
42: [23:09:42] * filisko has joined #silverstripe
43: [23:10:18] * filisko quit (Client Quit)

These logs were automatically created by ss-log on irc.freenode.net.