#silverstripe IRC Log

IRC log for 22 January 2017

All timestamps are in UTC.

1: [00:23:20] * Azure quit (Ping timeout: 252 seconds)
2: [00:36:39] * Azure has joined #silverstripe
3: [00:37:03] * Azure quit (Client Quit)
4: [00:50:50] * Azure has joined #silverstripe
5: [01:22:59] * gelignite_ has joined #silverstripe
6: [01:23:05] * micmania1 has joined #silverstripe
7: [01:26:46] * gelignite quit (Ping timeout: 264 seconds)
8: [01:32:12] * wmk_ has joined #silverstripe
9: [01:40:10] * wmk_ quit (Ping timeout: 240 seconds)
10: [03:31:04] * gelignite_ quit (Quit: http://bit.ly/1kso8Ta)
11: [05:46:34] * UncleCheese has joined #silverstripe
12: [05:47:31] * micmania1 quit (Quit: micmania1)
13: [05:53:51] * neilf__ has joined #silverstripe
14: [05:57:13] * micmania1 has joined #silverstripe
15: [06:24:16] * pweh has joined #silverstripe
16: [06:41:54] * micmania1 quit (Ping timeout: 260 seconds)
17: [06:45:05] * micmania1 has joined #silverstripe
18: [06:58:11] * slievr1 has joined #silverstripe
19: [06:59:24] * slievr quit (Ping timeout: 245 seconds)
20: [07:18:23] * pweh quit (Ping timeout: 276 seconds)
21: [07:20:53] * pweh has joined #silverstripe
22: [08:05:56] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
23: [08:10:43] * micmania1 quit (Quit: micmania1)
24: [08:46:47] * pweh quit (Ping timeout: 276 seconds)
25: [09:14:37] * neilf__ quit (Quit: Connection closed for inactivity)
26: [09:38:20] * pweh has joined #silverstripe
27: [09:43:22] * pweh quit (Read error: Connection reset by peer)
28: [10:58:20] * samsamek has joined #silverstripe
29: [11:29:20] * gelignite has joined #silverstripe
30: [11:30:23] <ss-helper> addons experiment - https://groups.google.com/d/msg/silverstripe-dev/K3dGQZumMTk/-nFtzKFGAAAJ
31: [14:50:08] * r5v3rb has joined #silverstripe
32: [14:52:39] <r5v3rb> anyone use focus point with stellar.js for parallax scrolling?
33: [14:53:06] <r5v3rb> I cannot get the initial position to maintain the ‘focuspoint’ that has been set
34: [15:26:42] * samsamek quit (Quit: samsamek)
35: [15:38:44] * r5v3rb quit (Quit: r5v3rb)
36: [16:20:34] * janneklouman-- has joined #silverstripe
37: [16:25:04] * DarjusIT has joined #silverstripe
38: [16:45:22] * samsamek has joined #silverstripe
39: [17:09:48] * helenclarko has joined #silverstripe
40: [17:10:01] <helenclarko> Hey all o/
41: [17:14:57] <DarjusIT> Hi, all I have discovered something odd for me. Situation is this: I have HomePage thats extends Page. In HomePage controller I have DB specific query, and then I deleted all content from page.ss (homepage.ss still exists) in browser you have white screen as it should be, but then you use ?showqueries it shows that DB query from HomePage controller is executed. Why? I have deleted all from page.ss so throw $layout homepage.ss not reachable, so
42: [17:14:57] <DarjusIT> why functions are executed? I tested this on 3.1 - 3.4 versions with no modules clean installs. this is odd.
43: [17:15:46] * helenclarko_mobi has joined #silverstripe
44: [17:19:20] <DarjusIT> when I clean data from homepage.ss then its not executing, I mean if page.ss dont have $layout it still executes functions that are called in homepage.ss
45: [17:40:38] <helenclarko> DarjusIT, I have the same issue at the moment. but the issue is that when pages are deleted/archieved it leaves data in the database and those are still being output to the homepage.
46: [17:41:13] <helenclarko> I need to check if a page is published, but I haven't worked that out yet.
47: [17:48:18] <DarjusIT> helenclarko, when you deleting and changing page with your function you need o rite and delete to all versions. In my case I deleted content from page.ss and it still executes queries from homepage controller because homepage.ss exists, but fact that page.ss is empty so homepage.ss not supposed to be executed.
48: [17:50:42] <helenclarko> DarjusIT, I'm pulling data from the dataobject, but it fails because it doesnt care if the page is published or not. I need to pull the data through the page somehow. I'm having a mind blank though.
49: [17:52:23] <DarjusIT> helenclarko, have you dev mode on?
50: [17:52:31] <helenclarko> Nevermind, I think I just worked it out.
51: [17:53:17] * helenclarko_andr has joined #silverstripe
52: [17:53:18] <ss-helper> helenclarko_andr: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
53: [17:53:49] * helenclarko_andr quit (Client Quit)
54: [17:54:22] <DarjusIT> helenclarko, because if you have dev mode on, in page queries you will have draft data included, on live mode it dont do this if I remember correctly
55: [17:54:30] * helenclarko_mobi quit (Ping timeout: 240 seconds)
56: [17:55:36] <helenclarko> So, I was using a ::get() on the dataobject rather than the page. I switched it to page, then looped over the dataobject through that. Now when I unpublish, the content is removed (Which is what I wanted).
57: [19:39:27] * janneklouman-- quit (Read error: Connection reset by peer)
58: [19:45:13] * janneklouman-- has joined #silverstripe
59: [19:54:30] * UncleCheese has joined #silverstripe
60: [19:55:38] * samsamek quit (Quit: samsamek)
61: [21:36:01] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
62: [22:18:27] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
63: [22:21:41] * UncleCheese has joined #silverstripe
64: [23:00:01] * ss-helper quit (Remote host closed the connection)
65: [23:00:18] * ss-helper has joined #silverstripe
66: [23:14:31] * samsamek has joined #silverstripe
67: [23:43:30] <helenclarko> Does anyone here take notice of pagespeed insights or is it just something I can ignore?
68: [23:45:39] <helenclarko> I mean I was originally using Defer on my script tags, but I'm now letting Silverstripe control the requirements. Insights now complains about "Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML"
69: [23:46:19] <helenclarko> SS 3.4.1 doesn't defer on its requirements
70: [23:52:06] * Ali_Alamshahi has joined #silverstripe
71: [23:52:16] <Ali_Alamshahi> hello all
72: [23:56:02] <Ali_Alamshahi> anyone has any idea why this form doesnt work: http://sspaste.com/paste/show/588542ba37438

These logs were automatically created by ss-log on irc.freenode.net.