#silverstripe IRC Log

IRC log for 5 October 2016

All timestamps are in UTC.

1: [00:15:03] <ss-helper> Silverstripe RecursiveTables Problems - http://stackoverflow.com/questions/39863555/silverstripe-recursivetables-problems
2: [00:38:47] * Hailwood quit (Ping timeout: 244 seconds)
3: [00:51:02] * Hailwood has joined #silverstripe
4: [00:54:07] * Azure quit (Quit: Oops.)
5: [00:57:05] * zippy has joined #silverstripe
6: [00:57:35] <zippy> Afternoon
7: [01:00:18] * zippy quit (Read error: Connection reset by peer)
8: [01:01:51] <spronk> lo
9: [01:16:14] * Hailwood quit (Ping timeout: 265 seconds)
10: [01:28:27] * Azure has joined #silverstripe
11: [01:35:41] * Hailwood has joined #silverstripe
12: [01:43:39] * muskie9 has joined #silverstripe
13: [01:51:22] * Azure quit (Remote host closed the connection)
14: [01:52:24] * zippy has joined #silverstripe
15: [01:52:35] <zippy> Stomach: spronk did either of you guys use Cloudflare?
16: [01:52:41] <Stomach> yeah we do
17: [01:52:42] * spronk did
18: [01:53:23] <zippy> I am noticing something strange today. When it's on I am getting intermitant javascript "parseerror" popups in the CMS
19: [01:53:33] <zippy> even the ajax ping command can trigger them
20: [01:53:50] <zippy> replicated it on 4 sites on 3 different servers.
21: [01:54:43] <spronk> hmm
22: [01:54:59] * Bollig|DesignCty has joined #silverstripe
23: [01:55:22] <zippy> chrome says "parseerror" firefox doesn't show an error but doesn't display the new content (like changing from Pages to a model admin)
24: [01:55:27] * micmania1 quit (Quit: micmania1)
25: [01:55:31] <zippy> safari also just "dies"
26: [01:56:12] <zippy> These sites are running 3.1.x - I am tempted to update to say, 3.3 but not sure if that will fix it
27: [01:56:18] <spronk> hmm
28: [01:56:40] <spronk> use page rules to turn off admin from it
29: [01:56:46] <zippy> tried that
30: [01:56:52] <spronk> still fucked up??? :S
31: [01:56:56] <zippy> yerp
32: [01:57:00] <spronk> are you sure it's a cloudflare error?
33: [01:57:11] <zippy> if I turn cloudflare off, issue goes away
34: [01:57:14] <spronk> hmm
35: [01:57:40] <zippy> I have 6 admin pages open. The ones on cloudflare will get the odd parseerror popup from the pings. The ones not on cloudflare I haven't seen a failed ping yet
36: [01:58:22] * micmania1 has joined #silverstripe
37: [01:58:27] <zippy> the headers also look fine, nothing overly different there
38: [01:59:36] <spronk> hmmmm
39: [01:59:45] <spronk> where is the js error ?
40: [01:59:56] <spronk> like it is on a specific file or something?
41: [02:00:27] <zippy> nothing logged in the console because I think it's wrapped in a catch for the nice error to show
42: [02:00:39] <zippy> so that is my next step, figure that out
43: [02:00:40] <muskie9> zippy we used it a while back... we had to alias something and do admin.oursite.com or something so we weren't hitting the cdn at all
44: [02:01:24] <muskie9> lotta somethings we did lol
45: [02:01:41] <spronk> hmmmm
46: [02:03:17] * Stomach_ has joined #silverstripe
47: [02:06:25] * Stomach quit (Ping timeout: 272 seconds)
48: [02:08:16] <zippy> mmm
49: [02:08:39] <zippy> Pretty rage inducing..
50: [02:08:47] <spronk> fucking web development eh
51: [02:09:34] <muskie9> CDN == Constant Disappointment Network... when it doesn't work
52: [02:09:47] <spronk> :D
53: [02:14:23] <zippy> fooking aye
54: [02:15:17] <muskie9> zippy what's worse... the cloudflare stuff or supporting worderp installs you didn't build
55: [02:16:54] <muskie9> it's easy they said... it'll be fun they said... https://puu.sh/ry78l/e8b8fecf47.gif
56: [02:16:57] <xyphoid> i like supporting magento installs i didn't build
57: [02:17:11] <xyphoid> wait i mean i don't like
58: [02:17:12] <zippy> is it possible to upgrade the framework jquery? 1.7.2 is facking old
59: [02:17:44] <muskie9> zippy frontend or cms?
60: [02:17:49] <zippy> cms
61: [02:17:55] <zippy> the framework/thirdparty/jquery/
62: [02:17:57] <muskie9> ya, that'll break stuff me thinks
63: [02:19:31] <muskie9> would be nice though to upgrade it
64: [02:21:45] <zippy> yea even 3.4 runs with 1.7.2
65: [02:22:23] <muskie9> 4's getting the upgrade afaik
66: [02:22:48] <muskie9> even talk of using the cdn link iirc
67: [02:23:47] <muskie9> pitfall of semvar? latest 3rd party dependancies might not be available for a while
68: [02:33:56] <spronk> hmm
69: [02:34:10] <spronk> are there any decent zero fee credit cards in nz? especially ones that have low foreign currency fees?
70: [02:54:08] * Stomach_ quit (Quit: zzz)
71: [02:56:14] * Stomach has joined #silverstripe
72: [03:29:40] * zippy quit (Quit: My MacBook has gone to sleep. ZZZzzz…)
73: [03:42:59] * muskie9 quit (Quit: Textual IRC Client: www.textualapp.com)
74: [03:43:22] * pandaux has joined #silverstripe
75: [04:13:26] * Stomach quit (Quit: zzz)
76: [04:14:12] * Stomach has joined #silverstripe
77: [04:24:19] <Bollig|DesignCty> Hey, has anyone worked with the blocks module to be able to set a bunch of default blocks that get created when the page is made?
78: [04:24:24] * Stomach quit (Quit: zzz)
79: [04:25:11] * Stomach has joined #silverstripe
80: [04:32:42] * pandaux quit (Ping timeout: 240 seconds)
81: [04:41:10] * Stomach quit (Ping timeout: 265 seconds)
82: [05:14:22] * micmania1 quit (Quit: micmania1)
83: [05:28:00] * Stomach has joined #silverstripe
84: [05:34:25] * Stomach quit (Read error: Connection reset by peer)
85: [05:35:03] * Stomach has joined #silverstripe
86: [05:54:16] * spronk quit (Quit: I may need a longer sleep timer...)
87: [06:03:15] * Stomach quit (Quit: zzz)
88: [06:09:15] * veb is now known as muffinis
89: [06:09:25] * muffinis is now known as veb
90: [06:21:18] * Stomach has joined #silverstripe
91: [06:32:50] * Eliseth has joined #silverstripe
92: [06:33:15] * Stomach quit (Quit: zzz)
93: [06:35:23] * Stomach has joined #silverstripe
94: [06:46:16] <Eliseth> Morning
95: [06:46:42] <ss23> moin
96: [06:51:53] * wmk has joined #silverstripe
97: [06:54:21] <Eliseth> Still struggling with locate... My locale is set to NL_nl, as confirmed by both i18n::get_locale() in the controller, as well as $ContentLocale in my page template.
98: [06:54:28] <Eliseth> *locale
99: [06:55:08] <Eliseth> Yet, when calling $MyDate.FormatI18N('%b'), it still displays the month in English
100: [06:55:21] <Eliseth> (I checked, and nl_NL is installed on the machine)
101: [06:56:41] * darianno has joined #silverstripe
102: [07:26:28] <Eliseth> wmk \o/
103: [07:26:46] <wmk> Eliseth, hi ho
104: [07:26:47] <wmk> wassup?
105: [07:27:05] <Eliseth> Can't get months translated in my template :(
106: [07:27:06] <wmk> shouldn't locale be nl_NL ?
107: [07:27:38] <Eliseth> Yes, it is. Typo above
108: [07:27:43] <wmk> is that locale installed on your machine with the right charset?
109: [07:27:48] <wmk> e.g. nl_NL@utf-8
110: [07:27:49] <wmk> ?
111: [07:27:55] <Eliseth> nl_NL
112: [07:27:56] <Eliseth> nl_NL.ISO8859-1
113: [07:27:56] <Eliseth> nl_NL.ISO8859-15
114: [07:27:56] <Eliseth> nl_NL.UTF-8
115: [07:27:56] <wmk> if it's not installed you're lost
116: [07:28:00] * marvanni has joined #silverstripe
117: [07:28:59] <wmk> formatI18n just uses strftime
118: [07:29:05] <wmk> so, does this work manually?
119: [07:29:23] <wmk> http://php.net/strftime
120: [07:29:54] <wmk> echo strftime('%b', time());
121: [07:30:50] <Eliseth> Hm, no...
122: [07:31:35] <wmk> translatable or fluent?
123: [07:31:40] <wmk> or just single language?
124: [07:31:55] <wmk> did you set the locale with ini_set()?
125: [07:32:03] * zippy has joined #silverstripe
126: [07:32:04] <Eliseth> single, locate set in config
127: [07:32:15] <Eliseth> echo i18n::get_locale() . " - " . strftime('%B', time());
128: [07:32:16] <wmk> are you allowed to use ini_set in config?
129: [07:32:25] <Eliseth> Outputs: "nl_NL - October"
130: [07:32:27] <Eliseth> >.<
131: [07:33:17] <wmk> i did e.g. setlocale(LC_TIME, "de_AT.utf8"); in my config.php
132: [07:34:16] <wmk> and i18n::set_locale doesn't use php's setlocale()
133: [07:34:39] <wmk> but strftime needs this, see manual "Format the time and/or date according to locale settings. Month and weekday names and other language-dependent strings respect the current locale set with setlocale(). "
134: [07:34:47] <Eliseth> I used setlocale(LC_ALL, 'nl_NL');
135: [07:35:09] <Eliseth> setlocale(LC_TIME, "nl_NL.utf8"); gives the same output
136: [07:36:03] <wmk> what does setlocale(..) return?
137: [07:36:20] <wmk> http://php.net/manual/en/function.setlocale.php should return the set locale, if it returns false you have a problem
138: [07:37:14] <wmk> http://php.net/manual/en/function.setlocale.php also has some examples (also for a windows machine
139: [07:37:23] <Eliseth> I'm not on a windows machine :)
140: [07:37:23] <wmk> on windows you'd need nld_nld (wtf??)
141: [07:39:07] <wmk> so what does setlocale() return?
142: [07:39:12] <wmk> Eliseth, ^^
143: [07:39:51] <Eliseth> [Warning] setlocale() expects exactly 2 parameters, 0 given
144: [07:40:06] <wmk> :p
145: [07:40:16] <wmk> with your parameters of course ;)
146: [07:40:38] <Eliseth> nl_NL
147: [07:41:33] <wmk> strange.
148: [07:41:41] <wmk> is it your server? can you re-install the locales?
149: [07:42:23] <Eliseth> I'm beginning to think it must be somewhere in there, yes, as I cannot find a reason for the code to blame
150: [07:43:33] <wmk> yup.
151: [07:43:55] <wmk> i had to run dpkg-reconfigure locales (or something like that) once to get it working
152: [07:45:22] <zippy> I had to do
153: [07:45:23] <zippy> locale-gen en_NZ.UTF-8
154: [07:45:29] <zippy> dpkg-reconfigure locales
155: [07:45:55] <zippy> maybe change my de_AT.utf8 to en_NZ.UTF-8 and see how you go
156: [07:53:46] <Eliseth> Yup, it was my local machine... works perfectly fine on the server... \o/ for wasting 2 hours on nothing
157: [07:54:03] <Eliseth> Thanks anyway, learned a bit about locales nonetheless :D
158: [07:57:38] <zippy> i've wasted 6 hours today with cloudflare and javascript..
159: [08:08:57] * kinglozzer has joined #silverstripe
160: [08:11:52] * spronka has joined #silverstripe
161: [08:23:09] <zippy> spronka: I think upgrading from 3.1.x to 3.2.x solves it..!
162: [08:23:15] <spronka> m:O
163: [08:47:51] * Stomach quit (Quit: zzz)
164: [08:48:14] * Stomach has joined #silverstripe
165: [08:48:39] <zippy> lol. dialup.ihug eh :P
166: [08:51:15] <slievr> please tell me it's not actually dialup
167: [08:51:18] * Bollig|DesignCty quit (Quit: Bollig|DesignCty)
168: [08:51:23] <spronka> lol
169: [08:51:25] <spronka> dialup
170: [08:51:27] <spronka> yyikes Stomach
171: [08:52:59] * Stomach quit (Ping timeout: 265 seconds)
172: [08:53:57] <zippy> spronka: you flooded his dialup connection...
173: [08:54:01] <spronka> lol
174: [08:54:04] <spronka> :D
175: [08:54:05] <zippy> so many characters.... poof
176: [09:01:23] * Mike123 has joined #silverstripe
177: [09:09:13] <Mike123> Hey guys, anyone can help with this https://snag.gy/Q68piw.jpg ? why i could get that when i login to admin zone ?
178: [09:12:07] * krofek quit (Read error: Connection reset by peer)
179: [09:15:06] * DimiStripe quit (Quit: DimiStripe)
180: [09:15:36] * DimiStripe has joined #silverstripe
181: [09:17:14] <kinglozzer> Mike123: Do you have any whitespace before an opening <?php tag? (or after a closing ?> tag if you include those anywhere - which you shouldn't)
182: [09:17:23] <kinglozzer> I think I've seen similar issues caused by that
183: [09:34:33] <Mike123> kinglozzer, it's strange but i see this page OK, my client is seeing this, and i don't get a thing what's going on
184: [09:37:50] <kinglozzer> Mike123: Have you tested in their browser? Are they viewing the site in live mode, while you're viewing in dev mode?
185: [09:38:03] <kinglozzer> https://hackernoon.com/how-it-feels-to-learn-javascript-in-2016-d3a717dd577f#.3darexvvk (・_・;)
186: [09:42:33] * marvanni quit (Ping timeout: 248 seconds)
187: [09:43:16] <slievr> ain't that a fun article. It never ends.
188: [09:48:20] <Mike123> kinglozzer, no i haven't tested in their browser, but me and client are viewing site both in live mode
189: [09:50:40] <wmk> kinglozzer, whitespace is a good tip
190: [09:50:56] * wmk puts BOM in the the round
191: [09:51:46] <wmk> once i've seen a dev saving a php file with BOM, broke PHP, as it's some chars outside (before) opening <?php
192: [10:09:16] * wmk quit (Quit: Leaving)
193: [10:10:30] * zippy quit (Quit: My MacBook has gone to sleep. ZZZzzz…)
194: [10:39:43] * zippy has joined #silverstripe
195: [10:47:11] * Azure has joined #silverstripe
196: [10:54:30] * Hailwood quit (Disconnected by services)
197: [10:54:55] * Hailwood_Ghost has joined #silverstripe
198: [11:26:22] <zippy> damn.. it's back..
199: [11:26:35] <zippy> I think it might be because of the https...
200: [11:38:16] * kinglozzer bites the bullet with OS X Sierra
201: [11:38:18] <kinglozzer> wish me luck!
202: [11:38:32] * kinglozzer quit ()
203: [11:44:34] <zippy> ok, so 3.2 and 3.3 do the same thing when running over the https.
204: [11:44:35] <zippy> hm
205: [12:09:44] * pweh has joined #silverstripe
206: [12:20:27] * UndefinedOffset has joined #silverstripe
207: [12:22:30] * elgabbu has joined #silverstripe
208: [12:37:57] <zippy> so if I have a patch for 3.x - where can I stick it
209: [12:38:49] * samsam has joined #silverstripe
210: [12:38:49] <ss-helper> samsam: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
211: [12:38:57] <samsam> aaand I'm back
212: [12:41:12] * Mike123 quit (Ping timeout: 240 seconds)
213: [12:41:44] <samsam> So anyone has experience with "conditional" fields? Suppose you have dropdown "Type" that has 2 values (list-one and list-two). If you set it to list-one, the next two textfields will be textfield A and B, if you click on list-two the textfields will change to C and D
214: [12:42:48] <samsam> I was wondering how to design the database table for it, just one table with values A, B, C and D seems most logical
215: [12:43:18] * otterpocket has joined #silverstripe
216: [12:43:37] * kinglozzer has joined #silverstripe
217: [12:46:51] <zippy> wb kinglozzer
218: [12:46:59] <zippy> so if I have a patch for 3.x - where can I stick it
219: [12:47:41] <kinglozzer> zippy: 3.2 probably, unless it's a significant bug then maybe 3.1
220: [13:16:28] <elgabbu> hi i just subclassed dropdownfield and add it to a page getCMSFields
221: [13:16:55] <elgabbu> the drop down is missing some classes so style looks wrong
222: [13:17:05] <elgabbu> why is that?
223: [13:17:59] <elgabbu> ok sorted just had to add protected $extraClasses = array('dropdown');
224: [13:18:01] <elgabbu> cheers
225: [13:18:35] * pweh quit (Read error: Connection reset by peer)
226: [13:19:21] <samsam> At your service
227: [13:19:26] <slievr> ^
228: [13:20:50] * janneklouman-- quit (Ping timeout: 252 seconds)
229: [13:26:33] * janneklouman-- has joined #silverstripe
230: [13:41:10] * spronka quit (Quit: My MacBook Air has gone to sleep. ZZZzzz…)
231: [13:41:54] * janneklouman-- quit (Ping timeout: 264 seconds)
232: [13:53:12] * janneklouman-- has joined #silverstripe
233: [14:17:18] * janneklouman-- quit (Ping timeout: 264 seconds)
234: [14:38:48] * Eliseth quit (*.net *.split)
235: [14:51:17] * zippy quit (Quit: My MacBook has gone to sleep. ZZZzzz…)
236: [15:14:49] <samsam> return DataObject::get('Widget')->where("ID = 1")->Title;
237: [15:15:10] <samsam> This should return the column value of column "Title" as a string right?
238: [15:20:03] <kinglozzer> samsam: Nope
239: [15:20:23] <kinglozzer> Don't use where(), use filter() as it will handle escaping values for you
240: [15:20:41] <kinglozzer> But you can just do: Widget::get()->byID(1)->Title;
241: [15:21:06] <kinglozzer> If you're not using byID(), then you'll need to use ->First() - return DataObject::get('Widget')->where("ID = 1")->First()->Title;
242: [15:22:09] <samsam> Second suggestion works! Cheers
243: [15:22:43] <samsam> what do you mean with, it will handle escaping values?
244: [15:28:27] <kinglozzer> samsam: Well if you ever pass in user data like ->where('Title = "' . $_GET['query'] . '"');, that would be vulnerable to sql injection
245: [15:28:45] <kinglozzer> If you use ->filter('Title', $_GET['query']); then it will automatically be escaped for you
246: [15:29:32] <kinglozzer> Plus ->filter() has more features, like ->filter('Number:GreaterThan', 2); or ->filter('Title:PartialMatch', $query)
247: [15:46:22] * darianno quit (Quit: Textual IRC Client: www.textualapp.com)
248: [15:48:48] <samsam> Ah I see
249: [15:58:11] * UndefinedOffset quit (Quit: Leaving.)
250: [15:59:52] * UndefinedOffset has joined #silverstripe
251: [16:05:42] * samsam quit (Ping timeout: 240 seconds)
252: [16:25:51] * otterpocket quit (Ping timeout: 272 seconds)
253: [16:33:02] * DimiStripe quit (Quit: DimiStripe)
254: [16:41:52] * kinglozzer quit ()
255: [17:35:53] * Ali_Alamshahi has joined #silverstripe
256: [17:36:00] <Ali_Alamshahi> Hello all
257: [17:36:51] * Ali_Alamshahi quit (Client Quit)
258: [17:42:35] * Ali_Alamshahi has joined #silverstripe
259: [17:43:37] * gelignite has joined #silverstripe
260: [17:44:27] <Ali_Alamshahi> Anyone knows how to avoid rewriting hash links in silverstripe? seems this doesnt work: rewrite_hash_links: false
261: [17:50:59] * UndefinedOffset quit (Quit: Leaving.)
262: [17:57:31] * UndefinedOffset has joined #silverstripe
263: [18:20:18] * Ali_Alamshahi quit (Ping timeout: 264 seconds)
264: [18:27:37] * UndefinedOffset quit (Quit: Leaving.)
265: [18:32:16] * CodeTrap has joined #silverstripe
266: [18:37:25] * UndefinedOffset has joined #silverstripe
267: [18:42:14] * Ali_Alamshahi has joined #silverstripe
268: [18:58:12] * theruss has joined #silverstripe
269: [19:00:21] <ss-helper> SilverStripe user friendly HTML value in summary_field - http://stackoverflow.com/questions/39881699/silverstripe-user-friendly-html-value-in-summary-field
270: [19:03:33] * Ali_Alamshahi quit (Ping timeout: 272 seconds)
271: [19:23:29] * DimiStripe has joined #silverstripe
272: [19:23:50] * theruss quit (Ping timeout: 252 seconds)
273: [19:30:48] * Stomach has joined #silverstripe
274: [19:35:29] * Phlunk3 has joined #silverstripe
275: [19:36:16] * zippy has joined #silverstripe
276: [19:44:31] * Stomach quit (Quit: zzz)
277: [19:45:15] * Stomach has joined #silverstripe
278: [19:51:39] <zippy> goood morning
279: [20:03:35] <Hailwood_Ghost> Morning zip
280: [20:04:06] <Nightjar> Stomach, wtf u doing holmes
281: [20:04:38] <Nightjar> http://php.net/manual/en/ini.core.php#ini.post-max-size
282: [20:05:05] <Nightjar> gidday folks
283: [20:05:09] <Nightjar> ps ^
284: [20:05:12] <Nightjar> o/
285: [20:05:52] * Hailwood_Ghost is now known as Hailwood
286: [20:06:43] <Nightjar> Stomach,
287: [20:06:44] <Nightjar> Stomach,
288: [20:06:45] <Nightjar> Stomach,
289: [20:06:49] <Nightjar> bruh talk to me :>
290: [20:06:53] <Hailwood> Observes Nightjar's eventual decline into "Good bye => I Have a problem => HELLO => hello""
291: [20:07:05] <Stomach> hi Nightjar
292: [20:07:13] <Nightjar> sup!
293: [20:07:23] <Stomach> what do you mean what am I doing
294: [20:07:28] <Nightjar> Stomach, imma like, msg u n shit
295: [20:07:33] <Stomach> im following your fucking docs
296: [20:07:34] <Stomach> :D
297: [20:07:44] <Stomach> literal COPY PASTE => FATAL ERROR
298: [20:07:53] <Nightjar> because yml holmes
299: [20:07:57] <Nightjar> space all the things
300: [20:21:51] * theruss has joined #silverstripe
301: [20:32:23] * data-killer has joined #silverstripe
302: [20:32:23] <ss-helper> data-killer: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
303: [20:34:50] * data-killer has left #silverstripe
304: [20:41:05] * UndefinedOffset quit (Quit: Leaving.)
305: [20:41:09] <zippy> must of been a spy..
306: [20:41:12] * zippy quit (Quit: Textual IRC Client: www.textualapp.com)
307: [20:55:21] * micmania1 has joined #silverstripe
308: [20:56:48] <Nightjar> such spy
309: [21:09:26] * Stomach quit (Ping timeout: 252 seconds)
310: [21:10:29] * Stomach has joined #silverstripe
311: [21:10:34] <Hailwood> Clearly he was just in here hunting for more data to kill.
312: [21:11:46] <Nightjar> Much data, such death
313: [21:12:02] <Nightjar> very killer
314: [21:12:46] <Nightjar> wow
315: [21:26:56] * micmania1 quit (Quit: micmania1)
316: [21:27:30] * pandaux has joined #silverstripe
317: [21:55:29] * Stomach quit (Quit: zzz)
318: [21:56:50] <Hailwood> There's no way to phpdoc methods added to the Member DataObject is there?
319: [21:56:59] * samwalshnz has joined #silverstripe
320: [21:57:00] <Hailwood> *methods added via an extension
321: [21:59:36] * Ali_Alamshahi has joined #silverstripe
322: [22:01:12] * samwalshnz quit (Ping timeout: 240 seconds)
323: [22:02:00] * Stomach has joined #silverstripe
324: [22:04:41] * Ali_Alamshahi quit (Ping timeout: 272 seconds)
325: [22:07:12] * CodeTrap quit (Quit: CodeTrap)
326: [22:15:51] * Stomach quit (Quit: zzz)
327: [22:17:41] * Stomach has joined #silverstripe
328: [22:18:16] * micmania1 has joined #silverstripe
329: [22:25:37] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
330: [22:27:52] * Stomach quit (Quit: zzz)
331: [22:55:20] <Nightjar> yeh
332: [22:55:27] * spronk has joined #silverstripe
333: [22:55:28] <Nightjar> same way you normally would
334: [22:55:33] <Nightjar> It's still just a PHP class
335: [22:55:46] <Nightjar> Hailwood, &^
336: [22:59:56] <spronk> sigh
337: [23:00:02] * ss-helper quit (Remote host closed the connection)
338: [23:00:16] * ss-helper has joined #silverstripe
339: [23:06:09] <pandaux> anyone working with images : )
340: [23:07:26] <pandaux> Followed suggestion in changelog https://docs.silverstripe.org/en/4.0/changelogs/4.0.0/ but still can't get images to save in db
341: [23:10:05] <pandaux> So images get uploaded just fine, however path to asset doesn't get set in DB
342: [23:13:27] <theruss> You using dev-master or 4.0.0 rc1 or rc2?
343: [23:13:40] <theruss> Those docs will be for master :-)
344: [23:14:17] <pandaux> @theruss dev-master
345: [23:14:44] <theruss> Upgraded from 3.1.x or spanking new install?
346: [23:15:20] <pandaux> new install
347: [23:15:36] <Nightjar> err
348: [23:15:44] <Nightjar> by rc you mean _alpha_ right?
349: [23:15:49] <theruss> Mysql? (Not that it matters I don
350: [23:15:51] <theruss> 't spose
351: [23:16:00] <theruss> LOL yeah
352: [23:16:09] <Nightjar> 2 things:
353: [23:16:12] <Nightjar> 1) that's weird.
354: [23:16:29] <Nightjar> 2) 4.0.0 _alpha_ 2
355: [23:16:51] <pandaux> yes MySQL and yes SS4
356: [23:17:24] <Nightjar> so, you're uploading, it's creating an Image data object, saving it, but before it puts the path info into the object?
357: [23:17:40] <Nightjar> and the file is actually on the filesystem?
358: [23:18:11] <pandaux> yes to both, it uploads the file to the assets dir, however it wont get linked for some reason
359: [23:18:32] <Nightjar> 'linked' -> ???
360: [23:19:36] <pandaux> I have a Service (extends DataObject) that has an image upload
361: [23:20:39] <pandaux> Service has an image upload field
362: [23:20:45] * Stomach has joined #silverstripe
363: [23:21:11] <Nightjar> Right, sorry, that's not making much sense.
364: [23:21:44] <Nightjar> sspaste.com ;)
365: [23:22:26] <Nightjar> Even if it's just a similar example.
366: [23:22:42] <Nightjar> Also, are you managing this in the CMS?
367: [23:25:25] <Nightjar> welp...
368: [23:25:33] <Nightjar> I'll just go with guesses then.
369: [23:25:41] <Nightjar> It sounds like you're declaring:
370: [23:26:01] <Nightjar> private static $db = ['Image' => 'Image'];
371: [23:26:05] <Nightjar> this should be:
372: [23:26:16] <Nightjar> private static $has_one = ['Image' => 'Image']
373: [23:26:53] <Nightjar> pandaux, ^
374: [23:31:57] <pandaux> thnx will check
375: [23:56:08] * muskie9 has joined #silverstripe
376: [23:59:30] * Stomach quit (Quit: zzz)

These logs were automatically created by ss-log on irc.freenode.net.