#silverstripe IRC Log

IRC log for 8 April 2016

All timestamps are in UTC.

1: [00:00:01] * ss-helper quit (Remote host closed the connection)
2: [00:00:21] * ss-helper has joined #silverstripe
3: [00:25:02] * jules0x quit (Quit: Leaving)
4: [00:32:21] * muskie9 has joined #silverstripe
5: [00:35:06] * micmania1 quit (Quit: micmania1)
6: [00:37:33] * toddv has joined #silverstripe
7: [00:38:02] * toddv quit (Client Quit)
8: [00:40:05] * muskie9 quit (Quit: Textual IRC Client: www.textualapp.com)
9: [00:52:52] * Stomach quit (Quit: zzz)
10: [01:00:44] * wmk has joined #silverstripe
11: [01:16:26] * Stomach has joined #silverstripe
12: [01:17:58] * wmk quit (Read error: Connection reset by peer)
13: [01:29:08] * Tanger has joined #silverstripe
14: [01:38:07] * micmania1 has joined #silverstripe
15: [01:49:17] * zippy has joined #silverstripe
16: [01:49:49] <zippy> Got a weird issue.... on a 3.1.15 site, in the CMS when the pages load it says up the top right ina notice
17: [01:49:52] <zippy> "success"
18: [01:50:12] <zippy> so any ajax loading that triggers seems to show, success - so on page load when the tree comes in, fires success
19: [01:54:51] * Stomach quit (Quit: zzz)
20: [02:14:36] * willr quit (Quit: willr)
21: [02:15:18] <MichalKleiner> zippy: better than getting errors I suppose?
22: [02:15:33] <zippy> I suppose, but it's weird.
23: [02:15:44] <MichalKleiner> any customisation to entwine/js?
24: [02:15:54] <zippy> ajax requests to fetch the treeview and things and it does it. it seems high level..
25: [02:16:11] <MichalKleiner> any google/ga/anything that could use ajax?
26: [02:16:54] <zippy> only on remote, not local.
27: [02:17:10] <zippy> it's calling a cms js function to add the notice to the notice list (so shows on the right hand side 'success')
28: [02:17:31] <zippy> logged in and out, incognito window, same deal
29: [02:17:39] <zippy> but, only chrome not firefox....
30: [02:17:44] <zippy> the friday puzzle..
31: [02:18:53] <MichalKleiner> I'd suggest leaving it as is and it will fix itself
32: [02:19:12] <zippy> lol
33: [02:19:18] <zippy> or masking something really wrong
34: [02:32:26] * zippy quit (Quit: Textual IRC Client: www.textualapp.com)
35: [02:38:24] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
36: [02:42:19] * UncleCheese has joined #silverstripe
37: [03:07:14] * Stomach has joined #silverstripe
38: [03:09:10] * thatnzguy quit (Ping timeout: 250 seconds)
39: [03:22:40] * Stomach_ has joined #silverstripe
40: [03:25:17] * Stomach quit (Ping timeout: 268 seconds)
41: [04:00:05] * Stomach_ quit (Quit: zzz)
42: [04:06:29] * Stomach has joined #silverstripe
43: [04:13:12] * spronk quit (Quit: I may need a longer sleep timer...)
44: [04:16:52] * micmania1 quit (Quit: micmania1)
45: [04:20:30] * Phlunk3 quit (Remote host closed the connection)
46: [04:36:05] * Stomach quit (Quit: zzz)
47: [04:37:27] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
48: [04:38:59] * micmania1 has joined #silverstripe
49: [04:43:41] * Stomach has joined #silverstripe
50: [05:10:05] * Stomach quit (Quit: zzz)
51: [05:13:20] * Stomach has joined #silverstripe
52: [05:14:02] * Hailwood quit (Remote host closed the connection)
53: [05:27:34] * cheddam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
54: [05:29:41] * Liquide quit ()
55: [05:30:18] * micmania1 quit (Quit: micmania1)
56: [05:34:57] * cheddam has joined #silverstripe
57: [05:43:36] * Naveed quit (Quit: Page closed)
58: [05:45:59] * Stomach_ has joined #silverstripe
59: [05:47:14] * cheddam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
60: [05:48:34] * Stomach quit (Ping timeout: 240 seconds)
61: [05:59:30] * wmk has joined #silverstripe
62: [06:02:49] * Stomach_ quit (Quit: zzz)
63: [06:40:06] * Agilix_ has joined #silverstripe
64: [06:40:25] <Agilix_> Morning all o/
65: [06:45:26] <wmk> hey Agilix_
66: [07:04:00] * arnhoe has joined #silverstripe
67: [07:15:26] <ss-helper> Re: [silverstripe-dev] "Supported modules" and github.com/silverstripe-labs - https://groups.google.com/d/msg/silverstripe-dev/vgQZpUnxrI4/IXQehO5ZBAAJ
68: [07:20:22] * SH__ has joined #silverstripe
69: [07:22:46] * UncleCheese has joined #silverstripe
70: [07:48:40] * SH__ quit (Ping timeout: 250 seconds)
71: [07:53:39] * jackoconnor has joined #silverstripe
72: [07:53:53] * swaiba has joined #silverstripe
73: [07:55:26] <jackoconnor> Has anybody experienced an ‘Undefined offset: 16’ error with SortableGridField when dragging to next or prev page before? I’m guessing it’s 16 because the grid field has 15 entries per page. When I search for the issue I get nothing because the creator of the module has the alias ‘UndefinedOffset’ xD
74: [08:02:34] * kinglozzer has joined #silverstripe
75: [08:10:44] * Mike123 has joined #silverstripe
76: [08:18:34] <swaiba> jackoconnor nope - but I can say I've never had any issue with... https://github.com/silverstripe-australia/silverstripe-gridfieldextensions :)
77: [08:32:23] * slievr has joined #silverstripe
78: [08:37:36] * agent44 has joined #silverstripe
79: [08:45:38] * Teddy_ has joined #silverstripe
80: [08:47:26] * cheddam has joined #silverstripe
81: [08:48:47] <Teddy_> hey dudes, I got a function that i want to test if a gallery data object has images to look or else return null in this pastebin http://pastebin.com/xhf3Qidh however the function still returns as trying to access a non object. Is my if condition wrong ?
82: [08:51:13] <Agilix_> And what does the error report?
83: [08:51:16] <Agilix_> Ah wait
84: [08:51:38] <Agilix_> change if ($this->GalleryItems()->First()->Image()) { to if ($this->GalleryItems()) {
85: [08:51:44] <Agilix_> Does that do it?
86: [08:52:03] <Agilix_> Because you're already accessing in the if statement -> hence the error
87: [08:52:07] * cheddam quit (Ping timeout: 268 seconds)
88: [08:53:17] <Teddy_> Agilix_, nope :P still this error Call to a member function Image() on a non-object in /some-website/property.php on line 180
89: [08:53:58] <Teddy_> Agilix_, it's as if the if does not check for it before returning
90: [08:54:06] <Agilix_> So the if return a true anyway
91: [08:54:18] <Teddy_> yep, i think so
92: [08:54:56] <Teddy_> Agilix_, yep, returns true in all instances
93: [08:56:56] <Agilix_> if (!empty($this->GalleryItems())) { ?
94: [08:58:16] <Teddy_> Agilix_, if it helps, property is data object with a has_many to galleryItem
95: [08:58:22] <Teddy_> Agilix_, Fatal error: Can't use method return value in write context :P
96: [09:00:26] * cheddam has joined #silverstripe
97: [09:03:58] * Tanger quit (Quit: Tanger)
98: [09:06:33] * slievr quit (Ping timeout: 240 seconds)
99: [09:11:31] * swaiba quit (Remote host closed the connection)
100: [09:42:28] * Hailwood has joined #silverstripe
101: [09:51:32] * DimiStripe has joined #silverstripe
102: [09:54:09] * wmk quit (Ping timeout: 246 seconds)
103: [10:09:37] * slievr has joined #silverstripe
104: [10:39:17] * swaiba has joined #silverstripe
105: [11:02:03] * slievr quit (Ping timeout: 240 seconds)
106: [11:21:36] * jackoconnor quit (Quit: jackoconnor)
107: [11:26:07] * jackoconnor has joined #silverstripe
108: [11:39:43] * cheddam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
109: [11:45:53] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
110: [12:18:16] * UndefinedOffset has joined #silverstripe
111: [12:18:57] * jackoconnor quit (Quit: jackoconnor)
112: [12:20:35] * slievr has joined #silverstripe
113: [12:30:16] <ss-helper> How to customize CMS? - http://stackoverflow.com/questions/36499526/how-to-customize-cms
114: [12:54:59] * slievr quit (Ping timeout: 260 seconds)
115: [13:04:46] * UndefinedOffset quit (Quit: Leaving.)
116: [13:10:18] * slievr has joined #silverstripe
117: [13:14:53] * UndefinedOffset has joined #silverstripe
118: [13:16:44] * jackoconnor has joined #silverstripe
119: [13:49:18] * muskie9 has joined #silverstripe
120: [14:06:32] * Agilix_ quit (Ping timeout: 250 seconds)
121: [14:26:03] * arnhoe quit ()
122: [14:33:02] * UndefinedOffset quit (Quit: Leaving.)
123: [14:36:05] * agent44 quit (Quit: zzz)
124: [14:36:23] * agent44 has joined #silverstripe
125: [14:36:38] * UndefinedOffset has joined #silverstripe
126: [15:04:36] * Mike123 quit (Ping timeout: 250 seconds)
127: [16:00:39] <ss-helper> Re: Wrong README displayed in Addons - how is this determined? - https://groups.google.com/d/msg/silverstripe-dev/sgFpfrPza1U/t_xF22B2BAAJ
128: [16:07:30] * swaiba quit (Remote host closed the connection)
129: [16:15:20] <ss-helper> Silverstripe 3.3 - How can I save HTML formatted text into database from frontend form? - http://stackoverflow.com/questions/36504293/silverstripe-3-3-how-can-i-save-html-formatted-text-into-database-from-fronten
130: [16:17:43] * kinglozzer quit ()
131: [16:35:51] * Teddy_ quit (Ping timeout: 268 seconds)
132: [16:52:31] * jackoconnor quit (Quit: jackoconnor)
133: [17:04:06] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
134: [17:05:32] * muskie9 has joined #silverstripe
135: [17:24:40] * agent44 quit (Quit: zzz)
136: [17:25:19] * agent44 has joined #silverstripe
137: [17:25:25] * agent44 quit (Client Quit)
138: [17:48:26] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
139: [17:56:19] * muskie9 has joined #silverstripe
140: [18:15:33] * muskie9 quit (Ping timeout: 240 seconds)
141: [18:32:13] * muskie9 has joined #silverstripe
142: [18:44:48] * darjusIT has joined #silverstripe
143: [19:03:32] * darjusIT quit (Read error: Connection reset by peer)
144: [19:04:14] * x4j5 has joined #silverstripe
145: [19:15:44] <ss-helper> Re: Wrong README displayed in Addons - how is this determined? - https://groups.google.com/d/msg/silverstripe-dev/sgFpfrPza1U/njnjsDSBBAAJ
146: [19:21:25] * UncleCheese has joined #silverstripe
147: [19:26:32] * timotheus-booth has joined #silverstripe
148: [19:33:48] * ^pH- has joined #silverstripe
149: [19:34:28] * ^pH quit (Read error: Connection reset by peer)
150: [19:45:07] * x4j5 quit (Ping timeout: 248 seconds)
151: [19:45:45] <ss-helper> Re: Wrong README displayed in Addons - how is this determined? - https://groups.google.com/d/msg/silverstripe-dev/sgFpfrPza1U/TmTX7baCBAAJ
152: [19:57:25] <timotheus-booth> can you do if x in y with silverstripe
153: [19:57:40] <muskie9> timotheus-booth not sure what you mean
154: [19:58:27] <muskie9> like checking if something is in an array or something?
155: [19:58:30] <timotheus-booth> what im trying to achieve is <% if $Page not in ChildrenOf('foo') %> or something similar
156: [19:59:01] <timotheus-booth> just silverstripe is new to me so i cant quite figure it out
157: [19:59:09] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
158: [19:59:09] * ajmitch_ quit (Ping timeout: 276 seconds)
159: [19:59:19] <muskie9> ah, I don't think there's anything stock for that in the template language but you could probably whip up a quick controller method or something
160: [20:00:25] * DimiStripe quit (Quit: DimiStripe)
161: [20:01:00] <timotheus-booth> silverstrip.. "making easy things more complicated since ages ago"
162: [20:01:01] <timotheus-booth> lol
163: [20:01:58] <muskie9> well you don't want too much logic in your templates... that's not what those are for... handle the business logic in models/controllers so the html in the layouts/templates isn't so nasty
164: [20:02:39] <timotheus-booth> so is there any alternative way to achieve what im trying to do, which is to see 'if im currently in the children this page but not in the page itself'
165: [20:05:05] <muskie9> $isSection would return if you're in the section of a page...
166: [20:07:33] * ajmitch has joined #silverstripe
167: [20:07:34] * ajmitch quit (Changing host)
168: [20:07:34] * ajmitch has joined #silverstripe
169: [20:10:06] <timotheus-booth> yea or the page itself
170: [20:14:56] <timotheus-booth> ok i figured it out if $inSection('foo') and if $Parent('foo')
171: [20:14:58] * UncleCheese has joined #silverstripe
172: [20:24:53] * Stomach has joined #silverstripe
173: [20:26:20] * Stomach quit (Client Quit)
174: [20:27:56] * helenclarko has joined #silverstripe
175: [20:28:00] <helenclarko> Hey all
176: [20:28:21] <helenclarko> How the hell can I extend ModelAdmin without a dataobject?
177: [20:28:30] <helenclarko> I cant find any documentation
178: [20:36:19] * gelignite has joined #silverstripe
179: [20:36:59] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
180: [20:38:08] <muskie9> helenclarko would you then extend LeftAndMain?
181: [20:38:30] <helenclarko> Just left and main and not modeladmin
182: [20:38:40] <helenclarko> That makes sense
183: [20:39:18] <muskie9> ModelAdmin would be a reference on how to do that, I've never tried it, but that would be my guess... you need something in that left side bar that's not tied to a model
184: [20:45:20] * UndefinedOffset quit (Quit: Leaving.)
185: [20:49:18] <helenclarko> Yeah modeladmin works with dataobjects and creates gridfields, I dont want that. I just want another menu where I can add fields. Kind of like how you would extend siteconfig
186: [20:56:44] <helenclarko> muskie9: Any idea?
187: [20:58:07] <muskie9> I'd dig into this: https://github.com/silverstripe/silverstripe-siteconfig/blob/3/code/controller/SiteConfigLeftAndMain.php
188: [20:58:29] <muskie9> since it's not tied to a model and now is broken out a bit... it'd be a good starting point I think
189: [20:59:04] <muskie9> not really a whole lot in there it seems
190: [20:59:32] <muskie9> here's the meat of it: https://github.com/silverstripe/silverstripe-siteconfig/blob/3/code/controller/SiteConfigLeftAndMain.php#L39
191: [20:59:44] <muskie9> creating a new CMSForm to return
192: [21:07:41] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
193: [21:15:20] * toddv has joined #silverstripe
194: [21:17:05] * UncleCheese has joined #silverstripe
195: [21:17:16] <toddv> good afternoon! has anyone ever had issues with SS not adding attributes to their form? I am trying to add a Vue v-on attribute it is not rendering. I have traced through Form::getAttributesHTML and am seeing it in the $parts array.
196: [21:21:04] <muskie9> toddv you're using ->setAttribute() on your form?
197: [21:21:23] <toddv> yes.
198: [21:22:20] <toddv> http://kopy.io/PnLVR
199: [21:23:57] <muskie9> I've never used vue before, so I'm new to that... what is the ending attribute you're looking for it to insert?
200: [21:24:36] <toddv> v-on="submit: search"
201: [21:25:07] <muskie9> hmmmm, your attribute setup looks correct then
202: [21:25:45] <toddv> what's weird is that it has shown up once or twice, then the next 10 times I refresh, it won't show up...
203: [21:26:22] <muskie9> ya, that's weird
204: [21:28:26] <toddv> when I adjust code to ->setAttribute('data-url', 'test') it works like a charm
205: [21:29:10] <muskie9> try ->setAttribute('data-url', 'test:submit') to see if the : is mucking it up... not sure why it would
206: [21:30:57] <toddv> changed to ->setAttribute('v-on', 'test') and it doesn't show up again. It's the v-on that appears to the the issue!
207: [21:31:25] <toddv> tested ('date-url', 'submit:search') and was golden
208: [21:34:16] * muskie9 I'm wondering if something in here is mucking it up: https://github.com/silverstripe/silverstripe-framework/blob/3/forms/Form.php#L823
209: [21:40:10] <toddv> I thought that too, but when I set a break point before at line 866, $parts contains my attribute
210: [21:40:56] <muskie9> and if you set a break point below the method in `FormAttributes()` it's the same?
211: [21:41:05] <muskie9> it _should_ be
212: [21:43:19] * UncleCheese quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
213: [21:44:21] <toddv> can't set a breakpoint there
214: [21:45:26] <ss-helper> Silverstripe's Complete List of ORM methods - http://stackoverflow.com/questions/36509680/silverstripes-complete-list-of-orm-methods
215: [21:47:39] <toddv> do you know which template uses $FormAttributes when creating a custom front end form?
216: [21:48:19] <toddv> or the next step in the execution of rendering the form?
217: [21:49:45] <helenclarko> Thanks muskie9
218: [21:50:20] <muskie9> did that work helenclarko?
219: [21:57:36] <toddv> I've added an issue on github.
220: [22:01:27] * Ali_Alamshahi has joined #silverstripe
221: [22:01:46] <Ali_Alamshahi> Hello
222: [22:02:03] <muskie9> o/
223: [22:02:31] <Ali_Alamshahi> I have a problem, when someone comments on my site, the page will not be displayed after
224: [22:02:51] * toddv quit (Remote host closed the connection)
225: [22:03:54] <muskie9> Ali_Alamshahi the whole page doesn't display? no 404 or anything?
226: [22:04:08] <Ali_Alamshahi> just a blank page, no 404
227: [22:04:37] <muskie9> are you in dev mode with error reporting on (assuming you have this in a dev environment)?
228: [22:05:14] <Ali_Alamshahi> unfortunately I dont know how to enter dev mode! but I'm logged in to the site as admin
229: [22:05:24] <muskie9> are you on production?
230: [22:05:44] <Ali_Alamshahi> yes I'm a website designer, not good at php
231: [22:06:01] <muskie9> you should be able to add ?isDev=1 to the url... may have to re-authenticate... but that should put it in dev mode
232: [22:06:10] <muskie9> **put your session in dev mode
233: [22:06:21] <Ali_Alamshahi> how to put it in dev mode?
234: [22:06:35] <muskie9> http://yoursite.com/your-page/?isDev=1
235: [22:06:54] * toddv has joined #silverstripe
236: [22:07:07] <Ali_Alamshahi> should i leave a comment first? I deleted them all
237: [22:07:25] <muskie9> I guess the first thing is, have any changes been pushed to the site code wise? you may need to http://yoursite.com/dev/build?flush=all
238: [22:08:39] <Ali_Alamshahi> http://sspaste.com/paste/show/57082bd6b4bf1
239: [22:08:50] <Ali_Alamshahi> please check the error
240: [22:09:21] <muskie9> you might be running an older version of the comment module
241: [22:09:54] <Ali_Alamshahi> ok, then I need to reinstall the comments addon?
242: [22:10:00] <muskie9> that's what the deprecation usually means... something newer's been implemented and you're still calling old code... in your Layout file for your page type, are you calling $PageComments or $CommentsForm?
243: [22:11:17] <Ali_Alamshahi> this is what I call $Pagecomments
244: [22:11:19] * toddv quit (Ping timeout: 268 seconds)
245: [22:11:30] <muskie9> try $CommentsForm and see if it fixes it
246: [22:12:51] <Ali_Alamshahi> didnt fix it
247: [22:13:25] <muskie9> and you did it on HotelsEntry.ss?
248: [22:13:40] <Ali_Alamshahi> yes
249: [22:13:56] <Ali_Alamshahi> let me reinstall comments
250: [22:14:07] <muskie9> hmmmmm, there's probably something else somewhere causing it... but keep the $CommentsForm in there as that's the correct variable now
251: [22:14:48] <Ali_Alamshahi> guess I should update comments module first
252: [22:15:15] <muskie9> how are you managing modules for your site? composer? downloads from github?
253: [22:15:42] <Ali_Alamshahi> download from github
254: [22:16:33] <Ali_Alamshahi> and then I unpack it in its required folder
255: [22:16:40] <muskie9> gotcha, have you double checked you have all requirements for each module you're using?
256: [22:17:02] <Ali_Alamshahi> yes
257: [22:17:09] <Ali_Alamshahi> it used to work before
258: [22:17:25] <muskie9> what version of comments are you using
259: [22:18:31] <Ali_Alamshahi> just downloaded the latest version from github and updated it
260: [22:19:25] <muskie9> I think there are a few extra things to download then
261: [22:19:26] <muskie9> https://github.com/assertchris/hash-compat/tree/1.0.1
262: [22:19:49] <muskie9> https://github.com/colymba/GridFieldBulkEditingTools/tree/v2.1.5
263: [22:19:52] <Ali_Alamshahi> I download the master
264: [22:20:15] <muskie9> right, have you downloaded the 2 items above as well?
265: [22:20:58] <Ali_Alamshahi> yes, before, I'll download and reinstall them now
266: [22:23:31] <muskie9> where did you put the hash-compat download?
267: [22:23:44] <Ali_Alamshahi> in a folder called hash-compat
268: [22:24:07] <Ali_Alamshahi> should I install it somewhere else?
269: [22:24:23] <muskie9> when I do a composer install of comments it puts it in vendor/assertchris/hash-compat
270: [22:24:36] <muskie9> so you may need to create vendor and assertchris
271: [22:25:08] <Ali_Alamshahi> I already had a vendor folder in my root
272: [22:25:25] <Ali_Alamshahi> should I install it in assertchris folder there?
273: [22:25:43] <Ali_Alamshahi> or should I create a vendor folder in comments folder?
274: [22:25:54] <muskie9> yes, there should be an assertchris folder in vendor, then the hash-compat should go in the assertchris folder
275: [22:26:28] <muskie9> the vendor folder is for non-SilverStripe code libraries required for the project to run
276: [22:26:54] <muskie9> this is generated generally when utilizing composer for your package (module) management
277: [22:26:57] <Ali_Alamshahi> what about GridFiledBulkEditingTools?
278: [22:27:06] <muskie9> that should be in the site root
279: [22:27:11] <Ali_Alamshahi> ok
280: [22:28:10] <muskie9> it may be confusing at first, but check out composer as one file and a command or two pulls all requirements and places them in the correct place: https://getcomposer.org/
281: [22:29:46] <Ali_Alamshahi> composer was way confusing for me
282: [22:29:55] <Ali_Alamshahi> installed them all and did a build?flush=1
283: [22:30:25] <muskie9> you mean dev/build?flush=
284: [22:30:51] <Ali_Alamshahi> yes'
285: [22:31:27] <muskie9> perfect... give the commenting a try again and see if it's still broken
286: [22:32:15] <Ali_Alamshahi> yes
287: [22:32:26] <Ali_Alamshahi> still broken
288: [22:32:38] <muskie9> what version of SilverStripe do you have installed?
289: [22:32:56] <Ali_Alamshahi> with $CommentsForm nothing displays, not even the dev mode error
290: [22:33:07] <Ali_Alamshahi> with $PageComments it shows the dev error
291: [22:33:12] <Ali_Alamshahi> 3.1
292: [22:33:42] <muskie9> the page loads if there are no comments?
293: [22:34:27] <Ali_Alamshahi> yes
294: [22:34:55] <Ali_Alamshahi> how to exit the dev mode?
295: [22:35:48] <muskie9> you'll have to clear your session... try opening a browser window in private browsing/incognito mode... that will be a new session
296: [22:37:06] <Ali_Alamshahi> now I get a bad gateway error on my admin section
297: [22:37:18] <Ali_Alamshahi> happened before, have to wait a day I guess
298: [22:37:54] <Ali_Alamshahi> god! it works now!!!
299: [22:38:01] <Ali_Alamshahi> now I can see the comment!
300: [22:38:40] <Ali_Alamshahi> but when I'm in Dev mode it doesnt show the page and shows the same error
301: [22:38:40] <muskie9> ah, perfect!
302: [22:39:14] <muskie9> I wonder if there's something cached in your browser or something
303: [22:39:48] <muskie9> if you have a separate browser from those you've used double check the admin works... don't need that to stop working... it's kind of important ;)
304: [22:40:22] <Ali_Alamshahi> ok
305: [22:41:03] <Ali_Alamshahi> admin works now
306: [22:41:08] <muskie9> awesome@!
307: [22:41:13] <Ali_Alamshahi> I needed to log off and log in again
308: [22:41:18] <muskie9> makes sense
309: [22:42:00] <muskie9> so the main issue I think is when you updated and installed everything you had the hash-compat folder in the wrong spot
310: [22:42:27] <Ali_Alamshahi> yes I think so
311: [22:42:30] <Ali_Alamshahi> thanks a million
312: [22:42:42] <muskie9> no problem, glad we got it worked out
313: [22:42:51] <Ali_Alamshahi> yeah same here :-)
314: [22:46:02] <muskie9> well time for snacks... later all
315: [22:46:12] <muskie9> **snacks == beers
316: [22:46:18] * muskie9 quit (Quit: Textual IRC Client: www.textualapp.com)
317: [22:47:13] <Ali_Alamshahi> cheers
318: [22:49:40] * Ali_Alamshahi quit (Quit: Leaving)
319: [23:29:55] * toddv has joined #silverstripe
320: [23:34:34] * toddv quit (Ping timeout: 268 seconds)
321: [23:44:40] * helenclarko quit (Quit: Page closed)
322: [23:49:47] * toddv has joined #silverstripe
323: [23:54:06] * toddv quit (Ping timeout: 248 seconds)

These logs were automatically created by ss-log on irc.freenode.net.