#silverstripe IRC Log

IRC log for 15 March 2016

All timestamps are in UTC.

1: [00:03:31] * Firesphere quit (Ping timeout: 244 seconds)
2: [00:10:24] * micmania1 quit (Quit: micmania1)
3: [00:27:49] * Firesphere_ has joined #silverstripe
4: [00:35:47] * wilson has joined #silverstripe
5: [00:35:58] <wilson> *wilson
6: [00:36:10] * wilson is now known as Guest9315
7: [00:36:58] <Guest9315> Hi to all, my server response time is horribly slow: about 4.2s. Ive tested the same page with the images, but in an .html page, it came down to 1.2s. What gives? Is SS in cause?
8: [00:42:13] * Stomach quit (Quit: zzz)
9: [00:45:54] * jules0x quit (Quit: Leaving)
10: [00:50:06] * Guest9315 quit (Ping timeout: 252 seconds)
11: [00:53:22] * Tanger has joined #silverstripe
12: [00:58:08] * micmania1 has joined #silverstripe
13: [01:00:01] * Azure quit (Ping timeout: 240 seconds)
14: [01:00:33] * Azure has joined #silverstripe
15: [01:10:32] * micmania1 quit (Quit: micmania1)
16: [01:20:20] * Azure quit (Remote host closed the connection)
17: [01:25:42] * micmania1 has joined #silverstripe
18: [01:30:07] * Stomach has joined #silverstripe
19: [01:39:14] <robbieaverill> Any way I can use $controller->redirect() without losing Form session messages?
20: [01:43:31] <robbieaverill> Context: GridFieldRequestHandler
21: [01:46:13] <robbieaverill> $controller->getRequest()->addHeader('X-Pjax', 'Content') then $controller->redirect() seemed to do the trick
22: [01:58:13] * nontgor quit (Read error: Connection reset by peer)
23: [02:04:19] * UncleChe_ has joined #silverstripe
24: [02:17:21] * micmania1 quit (Quit: micmania1)
25: [02:18:05] <BrewNaked> If I have a DataObject for which I'm using a GridFieldConfig_RelationEditor GridField CMS form to manage... and this DataObject keeps track of its "Parent" DataObject via a ParentObject has_one relation, how would I tell the GridField to automatically set a new "Child" DataObject's "Parent" value?
26: [02:19:42] <BrewNaked> I'm adding a GridField into the CMSFields for the Parent... so that you can click on and edit any of its child objects, but also allows for the creation of a new "child" object... but the parent's ID isn't automatically getting to the child's ParentID field.
27: [02:20:31] <BrewNaked> ...if that makes any sense at all. Maybe I'll pastebin a version up...
28: [02:24:59] <BrewNaked> http://pastebin.com/8AxAs2Hk
29: [02:38:39] * Firesphere_ quit (Ping timeout: 276 seconds)
30: [02:41:09] * Firesphere_ has joined #silverstripe
31: [02:42:18] <DanaeNZ> Oh nooooo this zip functionality isn't working on the SS Platform
32: [02:45:50] <Stomach> whats that
33: [02:45:56] <Stomach> does it not deploy
34: [02:45:59] <Stomach> soo
35: [02:46:05] <Stomach> does it "naut deploy"
36: [02:46:06] <Stomach> bahahahaha
37: [02:46:20] * Stomach claps at himself
38: [02:46:40] <DanaeNZ> i'd laugh but i'm too stressed wheeee
39: [02:46:44] <DanaeNZ> nah it deploys
40: [02:46:58] <DanaeNZ> just it doesn't want to write to the ZipArchive
41: [02:47:09] <DanaeNZ> I thought it might be becuase it doesn't like the sys_temp_dir
42: [02:47:21] <DanaeNZ> but I even got rid of that and saved to assets
43: [02:47:27] <DanaeNZ> but still nah
44: [02:47:38] <DanaeNZ> I don't think I can debug either
45: [02:47:46] <Stomach> ss23 signal
46: [02:49:01] <ss23> sognal
47: [02:49:09] <Stomach> sugnal
48: [02:49:11] <DanaeNZ> ssssssignal
49: [02:49:13] <ss23> SAGGYNAL
50: [02:49:18] <DanaeNZ> seagull
51: [02:49:22] <ss23> snuggle
52: [02:49:26] <Stomach> Stephen Seagull
53: [02:49:30] <ss23> ss23
54: [02:49:31] <ss23> ss23
55: [02:49:43] <ss23> Stomach: Did you actually have a problem or something? :O
56: [02:49:43] <DanaeNZ> ss23
57: [02:49:52] <DanaeNZ> i did
58: [02:49:55] <Stomach> I ALWAYS HAVE A PROBLEM
59: [02:50:09] <ss23> :O
60: [02:50:14] <ss23> Whats up, you two?
61: [02:50:15] <Stomach> MY SONIC EMOJI ON SLACK IS SLIGHTLY SMALLER THAN MY KNUCKLES ONE
62: [02:50:17] <DanaeNZ> I don't know how to debug on my SS Platform instance ;___;
63: [02:50:17] * ss23 sits down to listen
64: [02:50:21] <ss23> haha
65: [02:50:28] <Firesphere_> What's the sonic emoji?
66: [02:50:28] <DanaeNZ> Stomach: that's a serious problem
67: [02:50:32] <Stomach> I know right
68: [02:50:41] <ss23> DanaeNZ: Debug the code? Like?
69: [02:50:54] <Stomach> ?debug=1
70: [02:50:57] <Stomach> isDev=1
71: [02:51:01] <Stomach> stage=Fucked
72: [02:51:13] <Stomach> flush=itAllAway
73: [02:51:29] <Stomach> Firesphere_ - sonic the hedgehog man
74: [02:51:30] <Firesphere_> showtemplate=1&showqueries=1&isDev=1&debug=1&stage=1&flush=all&tryagain=true
75: [02:51:31] <Stomach> get with the times
76: [02:51:42] <Firesphere_> I don't have a sonic emoji in slack :|
77: [02:52:23] <DanaeNZ> ss23: ZipArchive isn't writing properly, I've seen similar results when it can't access the temp directory because of permission issues, but I set it to write just to the baseFolder and still it did not work. Just extracts to a .cpgz file
78: [02:52:50] <DanaeNZ> I suppose I could copy the AMI or something
79: [02:52:54] <DanaeNZ> fffuuu
80: [02:53:05] <Stomach> Firesphere_: http://www.freesmileys.org/emoticons-games-001.php
81: [02:54:18] <Firesphere_> It's weird, my ZNC keeps connecting. But I can't connect _to_ it :|
82: [02:56:06] <ss23> DanaeNZ: And you don't get an error?
83: [02:56:11] <ss23> DanaeNZ: Like, do you have Greylog access/
84: [02:56:14] <ss23> Cause that logs all PHP errors
85: [02:56:57] <DanaeNZ> ss23: GreyLog? No I don't think so, can't see a link anywhere
86: [02:57:10] <DanaeNZ> I might use the chat thing to see if I can get access I guess
87: [02:57:31] <DanaeNZ> oop I found it
88: [02:57:54] <DanaeNZ> fuck yeh
89: [02:59:03] * micmania1 has joined #silverstripe
90: [02:59:22] <ss23> Yeah so greylog is just a big logging server that all errors/warnings/everything goes to (not just PPH stuff)
91: [02:59:26] <ss23> So if you ever have a warning/error, youcan see it there
92: [02:59:34] <ss23> DanaeNZ: Let me know if you need access quicker :)
93: [03:00:39] <Stomach> should have called it sapphirelog
94: [03:02:00] <DanaeNZ> I also have access cos LDAP or something
95: [03:18:15] * BrewNaked quit (Remote host closed the connection)
96: [03:18:21] <ss23> DanaeNZ: yeah, your ldap login is the same as your deploynaut login
97: [03:18:26] <ss23> lol Stomach, it's not our product :P
98: [03:18:53] <Stomach> build it yourselves
99: [03:18:58] <Stomach> thats like silverstripe mantra man
100: [03:19:00] <Stomach> come on :D
101: [03:19:37] <ss23> lol pls
102: [03:19:44] <ss23> deploynaut is just capistarano frontend!
103: [03:20:39] <DanaeNZ> nothing in the logs but i found a different kind of fix so I'll just try it out
104: [03:20:47] <DanaeNZ> i have a pub quiz i need to get to tonight
105: [03:20:50] <DanaeNZ> for charity
106: [03:20:51] <ss23> heh
107: [03:20:52] <DanaeNZ> that makes it ok
108: [03:20:58] <ss23> let me know if you want help debugging
109: [03:21:22] <DanaeNZ> thanks I shal ;___;
110: [03:25:31] <Firesphere_> sha1?
111: [03:26:20] <DanaeNZ> l
112: [03:35:49] * UncleChe_ quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
113: [03:38:04] * Stomach quit (Quit: zzz)
114: [03:43:12] * nontgor has joined #silverstripe
115: [03:58:12] * robbieaverill quit (Ping timeout: 252 seconds)
116: [04:02:59] * UncleChe_ has joined #silverstripe
117: [04:33:52] * UncleChe_ quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
118: [04:34:27] * micmania1 quit (Quit: micmania1)
119: [04:44:53] * DanaeNZ quit (Remote host closed the connection)
120: [04:45:26] * DanaeNZ has joined #silverstripe
121: [04:49:33] * DanaeNZ quit (Ping timeout: 240 seconds)
122: [04:51:15] * Firesphere_ quit (Ping timeout: 244 seconds)
123: [04:57:02] * UncleChe_ has joined #silverstripe
124: [05:07:02] * BrewNaked has joined #silverstripe
125: [05:09:59] * adrexia quit (Quit: My Mac has gone to sleep. ZZZzzz…)
126: [05:11:24] * BrewNaked quit (Ping timeout: 244 seconds)
127: [05:22:50] * robbieaverill has joined #silverstripe
128: [05:24:04] <robbieaverill> Good evening! I'd like to test a single module on CircleCI (because it offers free private repository testing) - there are obviously some gotchas in running unit tests for a module that isn't a working SilverStripe setup. I've had a quick look over the Travis support repository, could anyone give me a could of bullet points to look at for adapting something simple to allow me to run my module's tests on Circle?
129: [05:25:41] <robbieaverill> Note: I'd love it to be open source at some point, but for now it needs to be private :(
130: [05:41:14] * robbieaverill quit (Ping timeout: 252 seconds)
131: [05:44:13] * Ra__ has joined #silverstripe
132: [05:44:13] <ss-helper> Ra__: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
133: [05:48:34] * Ra__ quit (Ping timeout: 252 seconds)
134: [06:02:55] * r_a has joined #silverstripe
135: [06:02:55] <ss-helper> r_a: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
136: [06:37:52] * Sentro has joined #silverstripe
137: [06:38:04] * r_a quit (Ping timeout: 252 seconds)
138: [06:40:18] * willr quit (Ping timeout: 244 seconds)
139: [06:44:49] * Sentro quit (Quit: Sentro)
140: [06:47:20] * willr has joined #silverstripe
141: [06:48:03] * Sentro has joined #silverstripe
142: [06:48:16] * wmk has joined #silverstripe
143: [06:48:17] <Sentro> hello SilverStripe!
144: [06:49:33] <Sentro> Is there a silverstripe module to buld add existing records like checkbox selection and hit add?
145: [06:50:06] <Sentro> http://addons.silverstripe.org/add-ons/simonwelsh/gridfieldrelationhandler module is no longer working on SS 3.3 version.
146: [06:50:25] <Sentro> I’m encountering errors ERROR [Warning]: SS_HTMLValue::getContent(): ID already defined
147: [06:50:32] <Sentro> please help.
148: [06:55:57] * BrewNaked has joined #silverstripe
149: [07:00:27] * BrewNaked quit (Ping timeout: 244 seconds)
150: [07:08:07] * Mike123 has joined #silverstripe
151: [07:08:10] <willr> Sentro in the CMS or Front end?
152: [07:08:19] <Sentro> in the CMS
153: [07:10:22] <willr> gridfieldrelationhandler would seem to the be way to go then. I’d suggest hitting up for an update. Lookks like https://github.com/arillo/silverstripe-GridFieldRelationHandler is the most up to date
154: [07:15:23] * Sentro quit (Quit: Sentro)
155: [07:21:38] * Sentro has joined #silverstripe
156: [07:22:55] <Sentro> willr actually I took from there.
157: [07:23:57] <Sentro> is there an other option aside from GridFieldRelationHandler that has the feature to select multiple records ?
158: [07:27:19] <willr> Not that I’ve used in the past :9
159: [07:37:15] * MrTopless has joined #silverstripe
160: [07:38:19] * lerni has joined #silverstripe
161: [07:38:58] * swaiba has joined #silverstripe
162: [07:42:07] * mobiusnz has joined #silverstripe
163: [07:50:18] <wmk> Sentro, there are some pickerfields afaik
164: [07:50:50] <wmk> though i don't know if they work with 3.3
165: [07:50:51] <wmk> https://github.com/briceburg/silverstripe-pickerfield
166: [07:52:56] <Sentro> oh thanks wmk. I will try this one.
167: [07:53:47] <wmk> if it doesnt work on 3.3 please file an issue there
168: [07:58:19] * spronka has joined #silverstripe
169: [07:59:30] <Sentro> it’s working on 3.3 wmk. but the problem is it has no multiple selection :(
170: [08:11:54] * arnhoe has joined #silverstripe
171: [08:15:32] * Frans_Amsterdam has joined #silverstripe
172: [08:19:35] * willr quit (Ping timeout: 268 seconds)
173: [08:21:12] * Werner_2_ has joined #silverstripe
174: [08:21:52] * cheddam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
175: [08:23:48] * wmk quit (Ping timeout: 276 seconds)
176: [08:25:43] * mobiusnz has left #silverstripe
177: [08:34:08] * Agilix has joined #silverstripe
178: [08:34:08] <ss-helper> Agilix: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
179: [08:43:21] <Agilix> Hi
180: [08:43:48] <Agilix> I have a custom theme that is in the correct location, is selected in the settings but will not display. I already tried a flush
181: [08:43:51] <Agilix> Any ideas?
182: [08:45:10] * BrewNaked has joined #silverstripe
183: [08:46:16] * Werner_2_ is now known as wmk
184: [08:47:00] <wmk> Agilix, flush again ;) and debug it... WHAT does not display? are the pathes correct? Do you have basic templates in mysite (which overrules thems)
185: [08:47:35] <wmk> does it work in dev mode? did you invalidate caches? ...
186: [08:47:57] <Agilix> I should be in dev mode, it works on a colleague machine. But he is not here yet
187: [08:49:04] <Agilix> Flushed it again, no results
188: [08:49:18] <Agilix> Do I need to "build" the theme? Like with compass or something?
189: [08:49:48] * BrewNaked quit (Ping timeout: 268 seconds)
190: [08:51:01] <wmk> normally not. maybe the flush didn't work... or you have pages with old theme still in a cache (static publisher?)
191: [08:51:34] <wmk> or you set the old theme in siteconfig and the new only in config.yml?
192: [08:53:12] <Agilix> config does not set a default. The admin has set the new theme
193: [08:55:04] * cheddam has joined #silverstripe
194: [09:01:36] * kinglozzer has joined #silverstripe
195: [09:07:28] * Sentro quit (Quit: Sentro)
196: [09:09:58] <wmk> Agilix, hmm, maybe something is wrong with your config that siteconfig theme is ignored?
197: [09:10:09] <wmk> i ALWAYS set it in config.yml
198: [09:10:16] <wmk> kinglozzer, ☺/
199: [09:10:41] * Sentro has joined #silverstripe
200: [09:12:23] <kinglozzer> \o wmk
201: [09:18:13] <Agilix> I'll give it a try by setting it in the config @wmk
202: [09:19:58] <Agilix> Not working either
203: [09:20:16] <Agilix> hmmm this is annoying
204: [09:20:17] * Sentro quit (Quit: Sentro)
205: [09:20:21] <Agilix> :p
206: [09:20:26] <wmk> Agilix, it is, yes
207: [09:20:51] <wmk> so you have to debug what value for the current theme is set
208: [09:21:07] * Sentro has joined #silverstripe
209: [09:21:08] <wmk> and check where it comes from (config.yml, config.php, php code, database)
210: [09:21:34] <wmk> it should be basically the name of the path, something like /themes/<NAME>
211: [09:21:50] <wmk> grep over your code if it's set somewhere
212: [09:24:23] <Agilix> If I do ?showtemplate=1 I get the right theme
213: [09:24:31] <Agilix> this doesn't make sense
214: [09:27:44] * cheddam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
215: [09:28:02] * Tanger quit (Quit: Tanger)
216: [09:29:26] <Agilix> any more ideas wmk ?
217: [09:29:36] * Sentro quit (Quit: Sentro)
218: [09:29:43] <Agilix> It seems to come from the cache though
219: [09:29:54] <Agilix> Flushed it, removed the local cache, still the same result
220: [09:30:33] * Sentro has joined #silverstripe
221: [09:30:52] <wmk> hmm, can you disable browser cache also?
222: [09:31:26] <wmk> Agilix, memcached? maybe you have to clear this also?
223: [09:31:46] <Agilix> done, there is no memcached
224: [09:42:03] * Frans_Amsterdam quit (Ping timeout: 240 seconds)
225: [09:47:27] <Agilix> mwk got it, was a config issue. Colleague helped me out
226: [09:47:34] <Agilix> Thanks for the help :)
227: [09:48:45] * Frans_Amsterdam has joined #silverstripe
228: [09:50:59] * DimiStripe quit (Quit: DimiStripe)
229: [09:58:27] * spronka quit (Quit: My Mac has gone to sleep. ZZZzzz…)
230: [10:05:51] * Sentro quit (Quit: Sentro)
231: [10:11:39] * DimiStripe has joined #silverstripe
232: [10:32:48] * Azure has joined #silverstripe
233: [10:34:01] * BrewNaked has joined #silverstripe
234: [10:38:14] * Agilix quit (Ping timeout: 252 seconds)
235: [10:38:57] * BrewNaked quit (Ping timeout: 268 seconds)
236: [11:46:42] * UncleChe_ quit (Ping timeout: 244 seconds)
237: [12:20:48] * UndefinedOffset has joined #silverstripe
238: [12:21:46] * Agilix has joined #silverstripe
239: [12:21:52] <Agilix> K, another question. I added a public function follow and added it to the allowed actions. It is under the page controller. I guessed I could reach it from /page/follow but this does not seem to be the case? There is also no route.yml in this project
240: [12:22:33] * BrewNaked has joined #silverstripe
241: [12:26:24] <wmk> Agilix, did you flush after you added it to $allowed_actions?
242: [12:26:58] * BrewNaked quit (Ping timeout: 244 seconds)
243: [12:27:21] <Agilix> so every action requires a flush?
244: [12:28:09] <Agilix> not found though
245: [12:46:22] <Agilix> no ideas?
246: [12:48:16] <kinglozzer> Agilix: Can you paste the controller somewhere like http://pastie.org ?
247: [12:48:27] * kinglozzer bbiab
248: [12:49:54] <Agilix> It's alright, I got. Just another error now :) we'll get there :p
249: [12:49:59] <wmk> !paste Agilix
250: [12:50:00] <ss-helper> Agilix: Please paste your code using something like http://kopy.io/ or http://www.sspaste.com/ or https://gist.github.com/ and then paste the link here.
251: [12:50:03] <wmk> and of course...
252: [12:50:05] <wmk> !flussh Agilix
253: [12:50:10] <wmk> !flush Agilix
254: [12:50:10] <ss-helper> Agilix: Have you flushed? Try doing a ?flush=all and /dev/build then see if it's sorted. Do it twice for good measure ;-)
255: [13:00:55] <Agilix> http://pastie.org/10760669 is my controller, I'm getting a 500. So the 404 is cleared. But there is no real clue as to what is wrong and the error logs are not catching it
256: [13:01:19] <wmk> well, you should make your error logs catch it ;)
257: [13:01:27] <wmk> -> dev mode, error level etc...
258: [13:02:05] <wmk> also return true / false inside an action seems a bit weird
259: [13:02:06] <Agilix> But if I do anything in the controller like a die or var_dump then those are not used. It just keeps giving the 500
260: [13:02:17] <Agilix> Even if it's an ajax?
261: [13:02:46] <wmk> dunno if ajax can return a bool... maybe you should wrap it in json...?
262: [13:03:32] <wmk> and how do you call the action? do you have a Follow page? or do you have a route to the follow controller?
263: [13:03:38] <wmk> what version of SS are you using?
264: [13:04:03] <Agilix> I'm doing it with: http://pastie.org/10760677
265: [13:04:47] <Agilix> ss 3.2.1
266: [13:05:20] <wmk> and you have a route to /follow/ ?
267: [13:05:47] <wmk> btw: a 500 could be shown in your webserver error log
268: [13:05:53] <wmk> not ss error log
269: [13:06:10] <Agilix> my route.yml http://pastie.org/10760678
270: [13:06:33] <wmk> your controller is named Follow_Controller
271: [13:06:51] <wmk> the route points to FollowController
272: [13:06:55] <wmk> i guess that won't work
273: [13:10:16] <Agilix> Ah changed it
274: [13:11:00] <Agilix> Now I'm getting a welcome page :/ :p
275: [13:22:01] * spekulatius2 quit (Ping timeout: 240 seconds)
276: [13:26:56] * SH__ has joined #silverstripe
277: [13:29:08] <SH__> Are there any problems with using the :GreaterThan filter on a decimal value? Im getting a " Call to a member function setValue() on null " when trying to do this: http://pastebin.com/cdaHxEje
278: [13:31:18] * UndefinedOffset quit (Quit: Leaving.)
279: [13:34:48] * spekulatius2 has joined #silverstripe
280: [13:43:20] * Eliseth has joined #silverstripe
281: [13:48:53] * DanaeNZ has joined #silverstripe
282: [13:54:03] * DanaeNZ quit (Ping timeout: 240 seconds)
283: [13:55:37] * UndefinedOffset has joined #silverstripe
284: [14:03:58] * lerni quit (Remote host closed the connection)
285: [14:11:27] * BrewNaked has joined #silverstripe
286: [14:15:58] * BrewNaked quit (Ping timeout: 252 seconds)
287: [14:50:47] * Cassi has joined #silverstripe
288: [14:50:47] <ss-helper> Cassi: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
289: [14:53:12] <Cassi> I'm running silverstripe 2.4.1. Older I know . I'm having issues saving/publishing. error saving content. checked forums. no clear answers. was hoping someone could walk me through. not sure if that is what this chat is for. thanks
290: [14:57:40] <Cassi> It is when I'm adding new albums. I assumed it was an issue with how the folders are arranged. Unsure. (taking over this project from someone else).
291: [14:58:01] <nontgor> are you running in dev mode Cassi?
292: [14:58:08] <nontgor> so that you can see errors
293: [14:58:56] * Agilix quit (Ping timeout: 252 seconds)
294: [14:59:19] <Cassi> Not to seem dumb but I wasn't aware there was a dev mode. I'm in the admin UI.
295: [15:00:18] <Cassi> It doesn't show me errors. it just tells me when it can't save. I did use fire bug and such to see if it would show me and just an error 500
296: [15:01:44] <Cassi> Im very new to silverstripe. sorry. I normally use dreamweaver or visual studios. this is my first time using something like this for one of our clients.
297: [15:05:32] <nontgor> god how do you do this in 2.4 again...
298: [15:05:55] <Cassi> lol they're worried about updating and having issues so it is what it is lol i've tried
299: [15:06:19] <nontgor> do you have this in mysite/_config.php? Director::set_environment_type('dev');
300: [15:06:29] <swaiba> https://docs.silverstripe.org/en/2.4/installation/common-problems/
301: [15:06:36] <swaiba> Cassi ^^^
302: [15:08:32] <Cassi> so just to make sure I understand clearly i type this at ?isDev=1 the end of my url? god i sould dumb sorry!!!
303: [15:08:37] <Cassi> sound*
304: [15:09:12] <swaiba> not sounding dumb and yes "?isDev=1" no quotes
305: [15:09:29] <nontgor> I feel dumb for forgetting that :)
306: [15:09:41] <nontgor> no problem, we're all noobs at some point, I am currently learning Laravel
307: [15:11:23] <Cassi> it wants my login . would that be the same as my admin log in? sorry unsure.
308: [15:12:17] <Cassi> I was thinking about learning Laravel. Laracasts is amazing. I spent part of this year with python/java and C# lol
309: [15:12:47] <Cassi> I'm still def a noob lol thanks for being patient with me!
310: [15:15:57] <Cassi> it wants a cms login
311: [15:27:09] * travis-ci has joined #silverstripe
312: [15:27:10] <travis-ci> silverstripe/silverstripe-framework#7025 (post-2.4 - 37e16a0 : Daniel Hensby): The build is still failing.
313: [15:27:10] <travis-ci> Change view : https://github.com/silverstripe/silverstripe-framework/compare/648f22252b85...37e16a0bebae
314: [15:27:10] <travis-ci> Build details : https://travis-ci.org/silverstripe/silverstripe-framework/builds/116148071
315: [15:27:10] * travis-ci has left #silverstripe
316: [15:28:31] <swaiba> Cassi yes it's a cms login, more importantly an admin login
317: [15:28:31] * Eliseth quit (Read error: Connection reset by peer)
318: [15:30:14] * travis-ci has joined #silverstripe
319: [15:30:15] <travis-ci> dhensby/silverstripe-framework#675 (2.5 - 37e16a0 : Daniel Hensby): The build has errored.
320: [15:30:15] <travis-ci> Change view : https://github.com/dhensby/silverstripe-framework/compare/648f22252b85...37e16a0bebae
321: [15:30:15] <travis-ci> Build details : https://travis-ci.org/dhensby/silverstripe-framework/builds/116147217
322: [15:30:15] * travis-ci has left #silverstripe
323: [15:31:36] * travis-ci has joined #silverstripe
324: [15:31:37] <travis-ci> dhensby/silverstripe-framework#674 (2.5 - 648f222 : Damian Mooyman): The build has errored.
325: [15:31:37] <travis-ci> Change view : https://github.com/dhensby/silverstripe-framework/compare/522425728796...648f22252b85
326: [15:31:37] <travis-ci> Build details : https://travis-ci.org/dhensby/silverstripe-framework/builds/116146485
327: [15:31:37] * travis-ci has left #silverstripe
328: [15:32:15] * BrewNaked has joined #silverstripe
329: [15:33:17] * travis-ci has joined #silverstripe
330: [15:33:18] <travis-ci> dhensby/silverstripe-framework#676 (post-2.4 - 37e16a0 : Daniel Hensby): The build was broken.
331: [15:33:18] <travis-ci> Change view : https://github.com/dhensby/silverstripe-framework/compare/55178ac53b40...37e16a0bebae
332: [15:33:18] <travis-ci> Build details : https://travis-ci.org/dhensby/silverstripe-framework/builds/116147691
333: [15:33:18] * travis-ci has left #silverstripe
334: [15:35:50] <swaiba> thanks travis bickle
335: [15:36:49] <nontgor> Cassi: use my nontgor handle, I get a bouncing icon to alert me. Otherwise I'm watching cricket (22:36 my time, Thailand)
336: [15:38:02] <nontgor> Cassi: add this to mysite/_config.php Security::setDefaultAdmin('admin', 'password;);
337: [15:38:14] <nontgor> erm Security::setDefaultAdmin('admin', 'password');
338: [15:45:15] * swaiba quit (Remote host closed the connection)
339: [15:56:30] * SH__ quit (Ping timeout: 252 seconds)
340: [15:57:17] * Teddy_ has joined #silverstripe
341: [15:58:14] <Teddy_> anyway here know how to make the submisions on user defined fields not show the html in the cms when you view the submissions? Trying to print a submission prints the html markut as well
342: [16:05:18] * Mike123 quit (Ping timeout: 252 seconds)
343: [16:14:46] * MrTopless quit (Ping timeout: 252 seconds)
344: [16:15:56] <Cassi> Okay well the admin doesnt work . I emailed to see if they had another. I don't understand what you mean nontgor
345: [16:16:36] <Cassi> it wont go through. I did what you said. I was using the info I was given and It won't accept the password. it just resets for you to try again
346: [16:18:19] <Cassi> nontgor: tried it. no idea what im doing wrong.. gah! sorry!
347: [16:28:42] * wmk quit (Ping timeout: 276 seconds)
348: [16:29:30] * arnhoe quit ()
349: [16:30:59] <kinglozzer> Cassi: If you add Security::setDefaultAdmin('admin', 'password'); to mysite/_config.php, you should then be able to login with the username 'admin' and the password 'password', is that what you were trying?
350: [16:32:11] <nontgor> kinglozzer is probably more awake timezone wise Cassi :)
351: [16:32:30] <kinglozzer> It's 4:30pm here, so I'm basically half asleep nontgor ;)
352: [16:32:48] <kinglozzer> Post-lunch crawl to 5:30 when I can go home :D
353: [16:33:56] <Cassi> yes that is what im trying lol i understand now lol gahhh!
354: [16:44:16] * FrozenFire quit (Quit: There's no place like ~)
355: [16:44:34] * FrozenFire has joined #silverstripe
356: [17:12:42] <Cassi> kinglozzer: How do I do that. would you mind giving me a step by step?
357: [17:15:22] <kinglozzer> Cassi: Well, open mysite/_config.php in a text editor and paste that line in :P
358: [17:17:15] <Cassi> kinglozzer: I don't have full control of this site. I don't have any of the directorys or anything. all I have is an admin log in to the editor. which is just the cms and you can see the draft site. I just kinda got thrown into this in figuring out why it won't let me save/publish.
359: [17:17:38] <kinglozzer> Cassi: You're going to struggle to do that without any access to files or logs... :/
360: [17:18:01] <kinglozzer> I'd ask someone who has access to the server error logs to send you the contents. At least then you'll know what the error messages are
361: [17:18:39] <Cassi> I know :/ I've requested them from the client . I was just hoping there was other troubleshooting I could do in the meantime.
362: [17:20:00] * wmk has joined #silverstripe
363: [17:21:31] <Cassi> kinglozzer: thank you for pointing me on the correct path though. Do you think an update would make everything unstable and a lot of cleaning up? or do you think it could probably fix this error?
364: [17:23:20] <kinglozzer> Cassi: Hard to say, but I definitely wouldn't risk it without access to error logs etc
365: [17:23:32] <kinglozzer> Otherwise you could completely break it with no way to fix it
366: [17:23:40] <Cassi> kinglozzer: for sure . agreed. thank you. :)
367: [17:26:14] <kinglozzer> Good luck!
368: [17:26:20] * kinglozzer home time
369: [17:26:21] * kinglozzer quit ()
370: [17:26:40] * DanaeNZ has joined #silverstripe
371: [17:31:32] * DanaeNZ quit (Ping timeout: 260 seconds)
372: [17:45:46] * Cassi quit (Ping timeout: 252 seconds)
373: [17:57:15] * mcn has joined #silverstripe
374: [17:57:16] <ss-helper> mcn: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
375: [17:57:26] <mcn> hi all
376: [17:58:33] <mcn> starting to develop a theme against silverstripe-shop and just wondering how I can render out a link to empty the cart?
377: [18:00:53] * Frans_Amsterdam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
378: [18:02:48] * vanny has joined #silverstripe
379: [18:03:03] <vanny> hi all
380: [18:13:19] * arnhoe has joined #silverstripe
381: [18:14:56] * cheddam has joined #silverstripe
382: [18:16:32] * gelignite has joined #silverstripe
383: [18:17:51] * Cass_ has joined #silverstripe
384: [18:17:51] <ss-helper> Cass_: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
385: [18:22:32] * Stomach has joined #silverstripe
386: [18:28:57] <vanny> Cass hi
387: [18:32:29] * Frans_Amsterdam has joined #silverstripe
388: [18:37:31] * cheddam quit (Ping timeout: 250 seconds)
389: [18:40:48] * Stomach quit (Quit: zzz)
390: [18:58:06] * Frans_Amsterdam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
391: [19:10:26] <Cass_> vanny: hi!
392: [19:11:05] <vanny> are you new to SS
393: [19:11:53] * Stomach has joined #silverstripe
394: [19:12:49] <Cass_> I am yes. I'm working on an old site. of which i don't have server keys to. yet. trying to rearrange images and fix this guys error but its giving me trouble for sure. working with an older version 2.4.1
395: [19:13:57] <Cass_> i was here earlier to see how to get into dev mode but i can't change the php keys without being able to veiw them first so im stuck trying to troubleshoot in the CMS admin area
396: [19:14:48] <vanny> ouch, you will need the to get into the code to fix any coding bugs
397: [19:15:12] <vanny> Im still learning SS. Been working in it for under a year
398: [19:15:47] * DanaeNZ has joined #silverstripe
399: [19:16:48] <Cass_> for sure. it seems like a folder issue he has some named the same and dups of uneeded folder so I think its having trouble placing it so it won't save or publish because of that error. I just can't touch the names to save . I did get one folder to go in the right place and it took it but anything that has near the same name it wont. lol unsure ..go figure
400: [19:17:29] * Frans_Amsterdam has joined #silverstripe
401: [19:17:44] <Cass_> I wish i could send a screen shot. totally makes sense looking at it but i've been looking at it for 2 days so i could be wrong lol
402: [19:20:03] * DanaeNZ quit (Ping timeout: 246 seconds)
403: [19:20:34] <vanny> if you need to send code, you can use sspaste.com
404: [19:20:47] <vanny> if you can host the image, just put a link here to ie
405: [19:20:48] <vanny> it
406: [19:38:33] * robbieaverill has joined #silverstripe
407: [19:39:28] * Phlunk3 quit (Ping timeout: 264 seconds)
408: [19:44:52] * Phlunk3 has joined #silverstripe
409: [19:44:56] * vanny quit (Ping timeout: 252 seconds)
410: [19:46:32] * Cass_ quit (Quit: Page closed)
411: [19:59:29] * adrexia has joined #silverstripe
412: [20:07:30] * Frans_Amsterdam quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz…)
413: [20:17:06] * Stomach quit (Ping timeout: 246 seconds)
414: [20:17:29] * Firesphere_ has joined #silverstripe
415: [20:19:04] * Stomach has joined #silverstripe
416: [20:23:20] * DanaeNZ has joined #silverstripe
417: [20:26:09] * micmania1 has joined #silverstripe
418: [20:29:43] * UndefinedOffset quit (Quit: Leaving.)
419: [20:48:39] * wmk quit (Quit: nice to meet you ;))
420: [20:50:03] * arnhoe quit ()
421: [20:58:44] * UncleChe_ has joined #silverstripe
422: [21:03:06] * UncleChe_ quit (Ping timeout: 244 seconds)
423: [21:10:03] * Stomach quit (Quit: zzz)
424: [21:11:09] * Hailwood has joined #silverstripe
425: [21:17:49] * DimiStripe quit (Ping timeout: 268 seconds)
426: [21:21:12] * UncleCheese quit (Ping timeout: 244 seconds)
427: [21:27:36] * mcn quit (Ping timeout: 252 seconds)
428: [21:42:53] * Stomach has joined #silverstripe
429: [21:53:01] * Firesphere_ quit (Remote host closed the connection)
430: [22:25:31] * spronk has joined #silverstripe
431: [22:31:28] * gelignite quit (Quit: http://bit.ly/1kso8Ta)
432: [22:34:50] <DanaeNZ> well I've narrowed down that ZipArchive error
433: [22:35:05] <DanaeNZ> the ZipArchive::open is returning 1, which is ZIP_ER_MULTIDISK
434: [22:35:27] <DanaeNZ> and yes I'm doing a hard check for return val ie, if $result !== true
435: [22:35:45] <DanaeNZ> now to figure out what that error means woohoo
436: [22:38:44] <spronk> fuck. you. adobe. and. your. fucking. shit. fucking. software.
437: [22:38:52] * Stomach quit (Ping timeout: 264 seconds)
438: [22:40:40] <robbieaverill> I'm having a bit of trouble fixturing a DataObject in a unit test... one of the fields is returning null when I do $dataobject->MyFieldName while the others are fine - are there any gotchas for it?
439: [22:41:59] * JackOconnor has joined #silverstripe
440: [22:46:02] <robbieaverill> don't worry :) I had a onBeforeWrite() clearing values in certain conditions
441: [23:00:01] * ss-helper quit (Remote host closed the connection)
442: [23:00:17] * ss-helper has joined #silverstripe
443: [23:02:16] <robbieaverill> QQ for someone familiar with unit testing - the SS convention is to use user_error() instead of throwing Exceptions - how do you test those with SapphireTest?
444: [23:03:13] <DanaeNZ> why can't i find anything on the internet about multidisk zip creation and how to not do it
445: [23:03:55] * JackOconnor quit (Quit: Leaving)
446: [23:06:29] <micmania1> DanaeNZ: multidisk zip creation?
447: [23:06:42] <micmania1> What are you trying to do?
448: [23:07:05] <DanaeNZ> I'm getting the error code ZIP_ER_MULTIDISK
449: [23:07:28] <DanaeNZ> I'm tryna make a zip. Works on local environment, but after deploying to Platform it does not like it
450: [23:07:57] * Stomach has joined #silverstripe
451: [23:08:59] <micmania1> http://stackoverflow.com/questions/15381142/ziparchive-open-error-in-php - does that help?
452: [23:09:46] <DanaeNZ> micmania1: I did see that one but I kinda dismissed it, I'll give it a go now
453: [23:11:10] <DanaeNZ> Oooh, I forgot my local is running an older PHP ver than platform
454: [23:17:40] * spekulatius2 quit (Quit: Leaving)
455: [23:21:55] * EasyCo_ has joined #silverstripe
456: [23:24:09] <EasyCo_> Hey team, when using composer to install silverstripe modules, is there any difference between their install location in vendor folder vs just being in the root of the project?
457: [23:29:33] <EasyCo_> Ahhhh! https://docs.silverstripe.org/en/3.1/getting_started/directory_structure/#autoloading
458: [23:48:07] * aaron___ has joined #silverstripe
459: [23:48:07] <ss-helper> aaron___: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
460: [23:48:38] <aaron___> hey all, got a performance issue that I am hoping someone can shed some light on
461: [23:48:57] <aaron___> basically we have a vps running, with a seperate database server
462: [23:49:05] <aaron___> 4gb ram, 4 cpu's
463: [23:49:14] <aaron___> nginx/php-fpm config
464: [23:49:30] <aaron___> but we are getting very very slow response times when there are above 50 people using the site
465: [23:50:01] <aaron___> I've configured nginx to use all the processors and php5-fpm to have enough threads running
466: [23:50:17] <aaron___> we aren't using all the memory on either server, cpu's are basically at idle
467: [23:50:38] <aaron___> has anyone hit this issue before?
468: [23:52:20] <aaron___> tried using partial caching but it doesn't seem to make a difference (might not be doing this correctly though...)
469: [23:55:12] <EasyCo_> Have you looked at your DB settings?
470: [23:55:34] * n8_ has joined #silverstripe
471: [23:56:24] <n8_> Hey guys
472: [23:56:43] <n8_> before I go exploring, I can use a listboxField with a mnay_many right?
473: [23:56:50] <aaron___> as much as I know... I've been using 'show processlist' at the mysql end to see if there are any queries getting hung up, but nothing
474: [23:56:56] <aaron___> and enabled slow-logs in mysql
475: [23:56:59] <aaron___> but also nothing shows
476: [23:59:00] <micmania1> aaron___: Does top show what is slowing it down on either the web boxes or the db boxes?
477: [23:59:28] <micmania1> Also, if you’re running in VPS is it possible that other processes on the hardware are stealing resources?

These logs were automatically created by ss-log on irc.freenode.net.