#silverstripe IRC Log

IRC log for 10 March 2016

All timestamps are in UTC.

1: [00:02:29] * r_hector has joined #silverstripe
2: [00:04:21] * adrexia has joined #silverstripe
3: [00:17:15] * micmania1 quit (Quit: micmania1)
4: [00:28:30] * micmania1 has joined #silverstripe
5: [00:32:01] * Tanger has joined #silverstripe
6: [00:49:09] * spekulatius quit (Ping timeout: 248 seconds)
7: [00:51:47] * spekulatius has joined #silverstripe
8: [00:57:14] * Azure quit (Quit: Oops.)
9: [00:59:18] * Azure has joined #silverstripe
10: [01:02:33] <Tanger> Hey guys, does anybody know about comparing a time in MySQL with a converted timezone date?
11: [01:02:42] * Azure quit (Client Quit)
12: [01:02:51] <Tanger> for example, I wanna check if a SS_Datetime object is earlier or equal to a time in GTM
13: [01:02:53] <Tanger> *GMT
14: [01:04:23] * Azure has joined #silverstripe
15: [01:37:10] * robbieaverill quit (Ping timeout: 252 seconds)
16: [01:43:32] <Tanger> All good, crisis averted
17: [01:51:37] * Admonish has joined #silverstripe
18: [01:55:16] * camfindlay has joined #silverstripe
19: [01:58:09] <Admonish> Hey there everyone
20: [01:58:12] * BrewNaked quit (Remote host closed the connection)
21: [01:58:31] <camfindlay> Admonish: hi there o/
22: [01:59:00] <Admonish> I was just wondering if anyone has been successful in getting form templates to work with frontend silverstripe forms
23: [01:59:08] <Admonish> I havent been able to
24: [02:00:11] * BrewNaked has joined #silverstripe
25: [02:03:23] * BrewNaked quit (Remote host closed the connection)
26: [02:03:24] <camfindlay> Admonish: not quite sure what you mean, can you give more details?
27: [02:04:48] <camfindlay> maybe let us know what you’re attempting to do and what you have tried already?
28: [02:05:21] <Admonish> I can indeed. So read in the silverstripe documentation about form templates. From what I understand they are a way of changing the output form (and form field) code.
29: [02:06:04] <camfindlay> right gotcha, so you want to change the markup that the fields are wrapped in?
30: [02:06:13] <Admonish> yes
31: [02:06:27] <Admonish> or rather the checkbosSet fields markup
32: [02:06:33] <camfindlay> right, and what have you tried so far? (Maybe post a gist?)
33: [02:06:44] <Admonish> CheckboxSetField
34: [02:06:54] <Admonish> I can post a gist
35: [02:06:57] <Admonish> one sec
36: [02:11:37] <Admonish> here you are https://gist.github.com/mooror/cf29e3a8a43b523d9923
37: [02:11:39] <Admonish> a gist
38: [02:15:27] * robbieaverill has joined #silverstripe
39: [02:15:42] <camfindlay> Are you trying to change all instances of this form element or just for this form?
40: [02:15:55] <Admonish> just for this form
41: [02:18:37] <Admonish> Now im using ->setTemplate() to try to change it because I assume that im trying to change the input markup and not the holder.Im just going to quickly try using ->setFieldHolderTemplate() instead. Incase I assumed wrong
42: [02:21:17] <Admonish> no dice
43: [02:21:23] <Admonish> Didny work
44: [02:21:33] <Admonish> Didnt*
45: [02:29:40] * spronk quit (Quit: I may need a longer sleep timer...)
46: [02:31:51] <Admonish> How do you push fields to a form?
47: [02:32:24] <Admonish> Im going to try duplicating there example code and pushing the field into the form
48: [02:32:46] <Admonish> My spelling today
49: [02:42:07] * phorloop quit (Quit: Byeee...)
50: [03:01:14] * adrexia quit (Quit: My Mac has gone to sleep. ZZZzzz…)
51: [03:03:20] * mahfuz has joined #silverstripe
52: [03:10:41] * micmania1 quit (Quit: micmania1)
53: [03:12:29] * micmania1 has joined #silverstripe
54: [03:17:48] <Admonish> So camfindlay, I found that I can successfully change the template of the field BEFORE I push it into the form
55: [03:25:16] <camfindlay> oh nice, sorry for not replying just got caught up on some stuff.
56: [03:26:33] <camfindlay> If thats not documented so well it would be great if you jumped in and shared your knowledge in the documentation. You can hit the edit button bottom of any docs page to contribute :)
57: [03:26:39] <camfindlay> Admonish: ^
58: [03:27:35] <Admonish> I will for sure
59: [03:32:35] <camfindlay> awesome dude, thanks so much :D
60: [03:33:08] <camfindlay> Someone else will need to do the same one day, so you’re paying it forward.
61: [03:33:32] <Admonish> indeed. Though im not sure if they will accept my fork :D
62: [03:38:20] <camfindlay> Advice, in your pull request prefix the title with DOCS
63: [03:39:31] <Admonish> alright, I will make sure to do that
64: [03:40:27] <camfindlay> thanks man :D
65: [03:52:12] * BrewNaked has joined #silverstripe
66: [03:56:37] * BrewNaked quit (Ping timeout: 252 seconds)
67: [03:59:58] * Hailwood quit (Remote host closed the connection)
68: [04:01:59] * camfindlay quit (Quit: camfindlay)
69: [04:09:06] * micmania1 quit (Quit: micmania1)
70: [04:10:02] * adrexia has joined #silverstripe
71: [04:10:04] * robbieaverill quit (Ping timeout: 252 seconds)
72: [04:26:25] * TRB143 quit (Ping timeout: 240 seconds)
73: [04:26:33] * TRB143 has joined #silverstripe
74: [04:36:41] * scott1702 has joined #silverstripe
75: [04:37:23] * Stomach quit (Ping timeout: 248 seconds)
76: [04:54:04] * scott1702 quit (Quit: Leaving)
77: [05:27:40] * Admonish quit (Ping timeout: 244 seconds)
78: [05:28:36] * Shrike_Finland has joined #silverstripe
79: [05:30:05] * Shrike_Finland quit (Client Quit)
80: [05:39:32] * mahfuz quit (Ping timeout: 252 seconds)
81: [05:41:07] * BrewNaked has joined #silverstripe
82: [05:45:15] * BrewNaked quit (Ping timeout: 244 seconds)
83: [05:52:03] * krofek__ has joined #silverstripe
84: [05:54:35] * krofek_ quit (Ping timeout: 250 seconds)
85: [06:06:28] * Admonish has joined #silverstripe
86: [06:16:12] * Shrike_Finland has joined #silverstripe
87: [06:44:02] * Shrike_Finland quit (Quit: Leaving.)
88: [06:48:16] * Shrike_Finland has joined #silverstripe
89: [06:49:56] * deskmaster quit (Ping timeout: 252 seconds)
90: [07:16:37] * Mike123 has joined #silverstripe
91: [07:27:38] * nontgor has joined #silverstripe
92: [07:28:08] * swaiba has joined #silverstripe
93: [07:29:59] * BrewNaked has joined #silverstripe
94: [07:31:10] * wmk has joined #silverstripe
95: [07:34:29] * BrewNaked quit (Ping timeout: 260 seconds)
96: [07:44:39] <swaiba> j7Z9YJoTP
97: [07:44:54] <swaiba> oopps lol
98: [07:45:03] <swaiba> morning all
99: [07:57:15] * arnhoe has joined #silverstripe
100: [08:08:05] <nontgor> time for a password chage swaiba?
101: [08:08:12] * Admonish quit (Quit: ThrashIRC v2.9 sic populo comunicated)
102: [08:08:20] <swaiba> it was only half of one :)
103: [08:18:05] * lerni has joined #silverstripe
104: [08:19:35] <wmk> ja der lerni
105: [08:19:57] <wmk> swaiba, oh, so we can guess your pw in half the time now?
106: [08:20:27] <swaiba> you'll have to know what it is for first...
107: [08:21:54] <wmk> wasn't that kind of a bug with some security thing a year ago that it used always the same first half for encryption? So the 256bit encryption became a de-facto 128bit enc..?
108: [08:23:01] <swaiba> I've really no idea
109: [08:23:24] <swaiba> like I said you'll have trouble knowing what that half was for AND getting access to start using it
110: [08:23:44] <swaiba> but jezzz I'll change it just so I can get some peace lol
111: [08:24:30] * wmk got a wrench swaiba
112: [08:24:52] * swaiba never scared!
113: [08:25:04] <wmk> https://xkcd.com/538/
114: [08:25:57] * willr has joined #silverstripe
115: [09:18:50] * BrewNaked has joined #silverstripe
116: [09:23:18] * BrewNaked quit (Ping timeout: 244 seconds)
117: [09:24:35] <swaiba> is the bot not around?
118: [09:24:47] <swaiba> I thought it might report on http://stackoverflow.com/questions/35910394/scaffold-listbox-multiple-select-in-modeladmin-filter-for-dataobject-with-enum by now
119: [09:25:10] * r_hector quit (Remote host closed the connection)
120: [09:26:04] <wmk> swaiba, nope, seems to be on holiday
121: [09:31:00] * r_hector has joined #silverstripe
122: [09:42:41] * Tanger quit (Quit: Tanger)
123: [09:45:45] * MrTopless has joined #silverstripe
124: [09:47:23] <MrTopless> How to create additional fields on start page, like lets say I want to add double jumbotron
125: [09:47:39] <MrTopless> Jumbotron split in 50%:50%
126: [09:47:50] <MrTopless> and title image and title description and link
127: [09:48:13] <MrTopless> Because now by default there is only on field for image and for description
128: [09:55:34] * Shrike_Finland quit (Quit: Leaving.)
129: [09:59:47] * HARVS1789UK has joined #silverstripe
130: [10:03:38] * Shrike_Finland has joined #silverstripe
131: [10:05:23] * willr quit (Ping timeout: 248 seconds)
132: [10:12:06] * HARVS178_ has joined #silverstripe
133: [10:12:35] * HARVS178_ is now known as HARVS1789UK_
134: [10:13:16] * g4b0_ has joined #silverstripe
135: [10:14:14] <g4b0_> hi all
136: [10:14:50] <g4b0_> any chance to have comments module forms bootstrap3 compatible?
137: [10:14:58] * HARVS1789UK_ quit (Client Quit)
138: [10:15:16] * HARVS1789UK quit (Ping timeout: 252 seconds)
139: [10:15:24] * HARVS1789UK has joined #silverstripe
140: [10:15:49] * Azure|dc has joined #silverstripe
141: [10:16:52] * Azure quit (Ping timeout: 260 seconds)
142: [10:18:19] * spronka has joined #silverstripe
143: [10:23:17] <HARVS1789UK> Morning all, leomeloxp has given me a crash course on composer yesterday and has been helping me make a few final fixes for our Mailchimp module
144: [10:24:24] <HARVS1789UK> If anyone is interested in using it and/or contributing by testing and submitting fixes, our beta release is now ready - https://github.com/Quadra-Digital/silverstripe-mailchimp-module
145: [10:29:14] * Azure|dc quit (Remote host closed the connection)
146: [10:39:14] * spronka quit (Quit: My Mac has gone to sleep. ZZZzzz…)
147: [10:42:40] <g4b0_> I'm trying to translate a module on transifex, but I get an error
148: [10:42:47] <g4b0_> There was an error connecting to server. Reload
149: [10:42:50] <g4b0_> any hint?
150: [10:43:03] <g4b0_> or it's just a transifex issue and I need to wait?
151: [10:57:57] * kinglozzer has joined #silverstripe
152: [11:07:45] * BrewNaked has joined #silverstripe
153: [11:11:57] * BrewNaked quit (Ping timeout: 246 seconds)
154: [11:17:53] <wmk> g4b0_, in the browser?
155: [11:22:15] * Shrike_Finland quit (Quit: Leaving.)
156: [11:23:49] <g4b0_> wmk: both chrome and firefox
157: [11:23:56] <g4b0_> on a linux box
158: [11:25:13] <wmk> g4b0_, it seems to work over here
159: [11:25:41] <g4b0_> maybe is a permissions issue?
160: [11:27:58] <wmk> maybe. but i can translate something for cms atm
161: [11:28:02] * r_hector quit (Ping timeout: 260 seconds)
162: [11:28:19] <wmk> maybe you don't have perms, maybe some bogus master file...
163: [11:31:16] * r_hector has joined #silverstripe
164: [12:27:44] <g4b0_> I'm trying to translate the comments module
165: [12:30:19] * nontgor quit (Ping timeout: 244 seconds)
166: [12:30:56] * Shrike_Finland has joined #silverstripe
167: [12:47:52] * r_hector quit (Remote host closed the connection)
168: [12:56:34] * BrewNaked has joined #silverstripe
169: [12:57:20] * elgabbu quit (Ping timeout: 252 seconds)
170: [13:01:07] * BrewNaked quit (Ping timeout: 252 seconds)
171: [13:08:05] * DimiStripe has joined #silverstripe
172: [13:15:03] * MrG has joined #silverstripe
173: [13:15:26] * MrG is now known as Guest78584
174: [13:19:35] <Guest78584> Is it possible to use ModelAdmin for a subgroup of Dataobjects?
175: [13:19:52] <Guest78584> (members of a group or other criteria)
176: [13:23:15] * UndefinedOffset has joined #silverstripe
177: [13:23:28] * Shrike_Finland quit (Quit: Leaving.)
178: [13:23:37] * Shrike_Finland has joined #silverstripe
179: [13:25:33] <wmk> Guest78584, yes, just overwrite your modeladmin's getList() to filter for your criteria
180: [13:29:13] <HARVS1789UK> Has anyone got any experience with the SS caching process timing out on a shared server (Fasthosts - they limit script execution time to 60 seconds)
181: [13:29:43] <wmk> caching process?
182: [13:29:49] <HARVS1789UK> Most importantly, it only happens after a period of time (presumably linked to the size of the cache dir and/or the number of files within it)
183: [13:29:56] <HARVS1789UK> SS partial caching
184: [13:30:05] <wmk> shouldn't take 60 seconds
185: [13:30:19] <HARVS1789UK> It doesnt on any other environment
186: [13:30:20] <wmk> or do you mean ?flush
187: [13:30:36] <HARVS1789UK> no flush, just loading a web page which uses partial caching
188: [13:30:45] <wmk> flushing might take ages (at least on my dev VM)
189: [13:31:05] <wmk> well, if the cache is outdated / invalidated you have to re-calculate
190: [13:31:13] <wmk> that might take some time
191: [13:31:41] <HARVS1789UK> It takes approx 9 seconds on my most complicated page
192: [13:31:48] <HARVS1789UK> and normally all works fine
193: [13:31:54] <wmk> normally, yes ;)
194: [13:32:15] <HARVS1789UK> until (after some randon time period and/or number of cache files have piled up) it dies horribly and takes > 60 seconds instead of 4-9 secs
195: [13:32:30] <HARVS1789UK> if I empty the cache dir manually, all goes back to normal
196: [13:32:34] <HARVS1789UK> ...for a while
197: [13:32:39] <HARVS1789UK> then it repeats
198: [13:33:23] <HARVS1789UK> I am stuggling to debug it as none of the URL debug flags work (i.e. ?debug) as the server never starts the response back to the client
199: [13:33:45] <wmk> HARVS1789UK, check the weberserver's error logs
200: [13:33:50] <wmk> maybe some file permission stuff?
201: [13:34:08] <HARVS1789UK> I have tried putting an SS_Backtrace::backtrace() in somewhere, but I don't know where, in Page.php init() never gets reached
202: [13:34:57] <HARVS1789UK> I have checked the error logs, only 2 entries for each page load:
203: [13:35:02] <HARVS1789UK> 1: mod_fcgid: read data timeout in 60 seconds
204: [13:35:17] <HARVS1789UK> (i.e. script execution limit of 60s reached)
205: [13:35:26] <HARVS1789UK> 2: nd of script output before headers: php56-cgi
206: [13:35:32] <HARVS1789UK> *End
207: [13:35:43] <HARVS1789UK> (i.e. you surpassed the time limit)
208: [13:36:06] <wmk> apache or nginx?
209: [13:36:19] <HARVS1789UK> file permissions all look OK to me :-(
210: [13:37:21] <HARVS1789UK> With Fasthosts the web server itself runs apache, but in CGI/FastCGI mode (not sure what that means), then they have some kind of relaying nginx server inbetween the web server and the client
211: [13:37:48] <HARVS1789UK> but this issue seems to only be related to the Apache CGI/FastCGI side of things
212: [13:38:14] <HARVS1789UK> Their support team have been as useful as a chocolate fireman and im pretty much out of ideas
213: [13:38:27] <HARVS1789UK> next step is move server :-(
214: [14:01:30] * Guest78584 quit (Ping timeout: 252 seconds)
215: [14:36:09] * Shrike_Finland quit (Quit: Leaving.)
216: [14:45:28] * BrewNaked has joined #silverstripe
217: [14:47:37] * lerni quit ()
218: [14:49:49] * BrewNaked quit (Ping timeout: 244 seconds)
219: [14:53:24] <HARVS1789UK> Update: other non-silverstripe scripts execute fine (i.e. a phpinfo()) and if I add an erorr_log() in these plain old .php files, I see the resulting error log entry however....
220: [14:54:28] <HARVS1789UK> adding an error_log() at the very start of SS /index.php file and calling it directly AND adding an error_log() to the first line of framework/main.php shows nothing at all in the error log (and script execution times out after 60 secs)
221: [15:17:55] <wmk> HARVS1789UK, htaccess runs framework/main.php
222: [15:18:03] <wmk> not index.php when you're using mod_rewrite
223: [15:20:53] <HARVS1789UK> if I go to mysite.com/index.php manually, there is nothing in .htaccess to redirect that to framework/main.php?
224: [15:21:41] <HARVS1789UK> There is a RewriteCond for "if request DOES NOT end in .php" isn't there? so accessing index.php manually should work?
225: [15:28:39] * g4b0_ quit (Quit: Sto andando via)
226: [15:33:42] <swaiba> HARVS1789UK - not sure, remember that file exists in case the rewriting doesn't work and kinda fakes it
227: [15:48:57] * wmk quit (Quit: nice to meet you ;))
228: [15:51:17] * MrTopless quit (Ping timeout: 244 seconds)
229: [15:57:46] * swaiba quit (Remote host closed the connection)
230: [16:00:15] * joelpittet has joined #silverstripe
231: [16:02:23] * elgabbu has joined #silverstripe
232: [16:03:02] <elgabbu> hi, is there any place were I can hook in and do some extra logic to attempt to match a URL to page's URL segment?
233: [16:03:14] * Mike123 quit (Ping timeout: 252 seconds)
234: [16:14:26] * joelpittet quit (Remote host closed the connection)
235: [16:17:24] * BrewNaked has joined #silverstripe
236: [16:17:49] * arnhoe quit ()
237: [16:28:55] * auto9 quit (Remote host closed the connection)
238: [16:30:52] * muskie9 has joined #silverstripe
239: [17:15:10] * MrTopless has joined #silverstripe
240: [17:33:19] * kinglozzer quit ()
241: [17:40:22] <muskie9> any idea why a write() would create a new object rather than update a queried object? https://gist.github.com/muskie9/146a2161fbc6ee66f64e
242: [17:41:05] <muskie9> I'm doing this elsewhere with other objects and it works fine.... if I do a debug/die to check the code, then remove the debug/die and refresh (resubmit the form on refresh) the update works as it should...
243: [18:07:52] * vanny has joined #silverstripe
244: [18:14:03] <vanny> morning all
245: [18:14:24] <vanny> Why would I get this in my SQL when I know it has data. WHERE ("Category"."Name" = ?)
246: [18:17:42] <muskie9> vanny is something not being passed properly in a filter or something?
247: [18:17:56] <vanny> I just cant see what?
248: [18:18:18] <vanny> this is the line, and I mean it is basic Category::get()->filter(array('Name' => $CategoryName));
249: [18:18:42] <muskie9> what's the value of $CategoryName if you Debug::show() it
250: [18:19:26] <vanny> honey
251: [18:21:09] <muskie9> ya, that looks like it should work then
252: [18:21:45] <vanny> I dont have to tell it that $CategoryName is a string? I've never had to before
253: [18:21:55] <muskie9> shouldn't have to
254: [18:23:33] <vanny> even when I change to 'ID' => 1 I still get ? in SQL
255: [18:27:14] <muskie9> maybe dev/build and flush to see if there's anything botched in cache or db
256: [18:28:43] <muskie9> I have an issue today where I query an object, change the title and write, and it creates a new object instead of update the existing one... and I'm doing this on another object which works as it should:https://gist.github.com/muskie9/146a2161fbc6ee66f64e
257: [18:32:00] <vanny> weird, are you on 3.3?
258: [18:38:37] <vanny> ok, so it is happening on another DataObject::get() as well
259: [18:39:49] * Stomach has joined #silverstripe
260: [18:40:27] <vanny> this is doing my head in. Could it be that I am in a function from a route?
261: [18:40:47] * DimiStripe quit (Quit: DimiStripe)
262: [18:41:14] <vanny> stomach will know!!!
263: [18:41:19] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
264: [18:41:20] <Stomach> good morning
265: [18:41:29] <vanny> hey there.
266: [18:41:56] <Stomach> whats up
267: [18:41:56] * muskie9 has joined #silverstripe
268: [18:42:05] <muskie9> vanny 3.1
269: [18:42:14] <vanny> Any idea why Product::get()->filter(array('CategoryID' => 1)) would give me WHERE ("Product"."CategoryID" = ?)
270: [18:42:53] <muskie9> vanny so you're routing to a controller, then are in a method in that controller?
271: [18:43:40] <vanny> yeah to call a new template _category (which will list all the items it /category/honey) for instance
272: [18:43:56] <Stomach> is that ? in the output
273: [18:44:01] <Stomach> thats how prepared statements work
274: [18:44:54] <vanny> yeah, if I do a ->Sql() on the object I get a ?. Normally I would see that value passed. It also returns nothing
275: [18:46:30] <vanny> ok, so lied, it does return values but the ? in the output makes it hard to debug
276: [18:46:35] <Stomach> are you using 3.2? PDO will return the SQL like that
277: [18:47:04] <vanny> The latest 3.3
278: [18:47:12] <Stomach> yeah that will return like that
279: [18:47:12] <vanny> (stable version)
280: [18:47:17] <Stomach> agree its hard to debug
281: [18:47:42] <vanny> ok, well im glad it is not me, i feel a little better, I just need to work around it for debug
282: [18:49:20] <vanny> so I really need to Debug::show() rather than echo ->Sql() now :)
283: [19:05:08] <muskie9> so my write() to update the object works as expected if I pass true for the write's first argument to showDebug... which makes no sense
284: [19:13:34] * Audlex quit ()
285: [19:25:02] * HARVS1789UK quit (Quit: night all)
286: [19:25:29] <vanny> muskie9 are you using an onbeforewrite anywhere?
287: [19:25:51] <muskie9> not on that DataObject
288: [19:26:31] <muskie9> it's like it's processing the write before it knows there's an ID which makes no sense at all... triggering a debug of some kind makes it see the ID and update the existing record
289: [19:26:45] <vanny> on, I had some problems with that the other day, I didnt realise what it was doing, and I was doing an order of items, and it ran 35 times. when I expected it to run once
290: [19:27:36] <muskie9> I feel like I had this on another project but was a while ago, so can't remember what the cause was
291: [19:28:37] * helenclarko has joined #silverstripe
292: [19:28:55] <helenclarko> Morning!
293: [19:29:21] <helenclarko> Well, early morning I guess.
294: [19:32:39] * robbieaverill has joined #silverstripe
295: [19:33:20] <vanny> weird.
296: [19:40:31] * Copperis has joined #silverstripe
297: [19:42:09] * joelpittet has joined #silverstripe
298: [19:42:30] * helenclarko quit (Ping timeout: 252 seconds)
299: [19:56:12] * DimiStripe has joined #silverstripe
300: [19:58:34] * r3v3rb has joined #silverstripe
301: [19:59:41] <r3v3rb> hellooooo
302: [20:12:15] * Phlunk3 has joined #silverstripe
303: [20:13:40] * Phlunk3 quit (Remote host closed the connection)
304: [20:14:37] * micmania1 has joined #silverstripe
305: [20:28:29] * Pyromanik has joined #silverstripe
306: [20:45:12] * spronka has joined #silverstripe
307: [20:54:15] * spronka quit (Quit: My Mac has gone to sleep. ZZZzzz…)
308: [20:56:01] * spronka has joined #silverstripe
309: [20:57:37] * r3v3rb quit (Quit: Leaving)
310: [21:10:54] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
311: [21:11:12] * micmania1 quit (Quit: micmania1)
312: [21:11:38] * muskie9 has joined #silverstripe
313: [21:13:30] * Guest__ has joined #silverstripe
314: [21:14:17] * Guest__ quit (Client Quit)
315: [21:17:06] * Helion has joined #silverstripe
316: [21:20:25] * micmania1 has joined #silverstripe
317: [21:21:07] * cheddam has joined #silverstripe
318: [21:22:14] <Pyromanik> :O Johos!
319: [21:23:37] * joelpittet quit (Remote host closed the connection)
320: [21:23:40] <Pyromanik> At my door?
321: [21:23:44] <Pyromanik> It's more likely than I think!
322: [21:25:24] <cheddam> Can someone explain to me how setters on DataObjects work? I figured they'd act as a filter (return modified input) but since I implemented this the field is no longer saving changes :(
323: [21:27:42] <cheddam> related: https://gist.github.com/Cheddam/a79a596534e0b35be4f0
324: [21:37:51] * Helion quit (Quit: Page closed)
325: [21:45:56] * UndefinedOffset quit (Quit: Leaving.)
326: [22:14:43] <micmania1> cheddam: how are you calling it?
327: [22:17:16] * Stomach quit (Quit: zzz)
328: [22:19:13] <cheddam> micmania: eventually figured it out - you have to call $this->setField('x', $modifiedInput) instead of just returning it
329: [22:19:24] <cheddam> oops, micmania1
330: [22:19:46] <micmania1> cheddam: don’t forget the 1
331: [22:20:10] <cheddam> My superior experience in Laravel over SilverStripe strikes again :P
332: [22:20:15] <cheddam> lel
333: [22:23:09] * Azure has joined #silverstripe
334: [22:26:21] * Stomach has joined #silverstripe
335: [22:27:53] * DimiStripe quit (Quit: DimiStripe)
336: [22:29:40] * spronka quit (Quit: My Mac has gone to sleep. ZZZzzz…)
337: [22:38:44] <Copperis> cheddam, what are you using silverstripe for if you know laravel?
338: [22:40:20] <cheddam> Copperis: Hahaha, they each have their strengths, but SS seems to make less sense in places
339: [22:42:49] <micmania1> cheddam: you make less sense in places
340: [22:43:13] <cheddam> I make no sense in a lot of places, it's true
341: [22:43:36] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
342: [22:44:20] * Phlunk3 has joined #silverstripe
343: [22:52:51] * muskie9 has joined #silverstripe
344: [23:00:14] * ss-helper has joined #silverstripe
345: [23:01:41] * Mitcheru-san has joined #silverstripe
346: [23:01:42] <ss-helper> Mitcheru-san: Welcome to #silverstripe! Please ask your questions but don't leave too soon, we are a busy lot.
347: [23:02:23] <Mitcheru-san> Hi all, I don't suppose anyone has used this before? https://github.com/heyday/silverstripe-versioneddataobjects/
348: [23:04:47] * micmania1 quit (Quit: micmania1)
349: [23:32:46] <Pyromanik> Mitcheru-san, nope, I suppose quite a fair number of people have, actually.
350: [23:32:59] * muskie9 quit (Quit: My Mac has gone to sleep. ZZZzzz…)
351: [23:33:01] <Pyromanik> o/ ss23
352: [23:33:14] <ss23> o/
353: [23:33:50] <Pyromanik> looking for the Next Best Thing (tm) ?
354: [23:34:33] <ss23> Pretty much
355: [23:34:52] <Pyromanik> ss23, have you heard of JavaScript?
356: [23:34:53] <Pyromanik> xD
357: [23:35:00] <Pyromanik> They love the next best things
358: [23:37:34] <Pyromanik> ss23, what kinda shit you after?
359: [23:37:47] <Pyromanik> More web based? C? idk.
360: [23:37:50] <Stomach> Mitcheru-san - yes I have
361: [23:43:30] * muskie9 has joined #silverstripe
362: [23:51:26] * Stomach quit (Quit: zzz)
363: [23:55:04] <vanny> Ok, so this has me confused and not sure what I am doing wrong.
364: [23:56:14] * muskie9 quit (Ping timeout: 248 seconds)
365: [23:56:29] <vanny> I have a function add()on Page.PHP that generates a small form. I should be able to call it from any template. But when it is inside a with block, it doesnt return anything, even if I use $top.add()
366: [23:57:19] * Stomach has joined #silverstripe

These logs were automatically created by ss-log on irc.freenode.net.