#silverstripe IRC Log

IRC log for 12 May 2013

All timestamps are in UTC.

1: [00:42:00] * ss-log has joined #silverstripe
2: [00:45:00] * travis-ci has left #silverstripe
3: [00:45:00] * travis-ci has joined #silverstripe
4: [00:45:00] <travis-ci> [travis-ci] silverstripe/sapphire#2215 (3.1 - 0f7a5d2 : Will Rossiter): The build has errored.
5: [00:45:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/7ade1ebd594c...0f7a5d29c831
6: [00:45:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7090324
7: [00:51:00] * simon_w|air has joined #silverstripe
8: [00:52:00] * simon_w quit (Read error: Connection reset by peer)
9: [00:54:00] * simon_w has joined #silverstripe
10: [00:59:00] * Zauberfisch|idle has joined #silverstripe
11: [00:59:00] * spronk2_ has joined #silverstripe
12: [01:02:00] * priithansen quit (Quit: priithansen)
13: [01:02:00] * Kolin_ has joined #silverstripe
14: [01:02:00] * jonstahlhacke__ has joined #silverstripe
15: [01:03:00] * Liquide^2 has joined #silverstripe
16: [01:04:00] * Liquide quit (Ping timeout: 245 seconds)
17: [01:04:00] * Kolin quit (Ping timeout: 245 seconds)
18: [01:04:00] * Zauberfisch-idle quit (Ping timeout: 245 seconds)
19: [01:04:00] * spronk2 quit (Ping timeout: 245 seconds)
20: [01:04:00] * Ian_Harris quit (Ping timeout: 245 seconds)
21: [02:23:00] * eikonos quit (Read error: Connection reset by peer)
22: [02:24:00] * eikonos quit (Changing host)
23: [02:24:00] * eikonos has joined #silverstripe
24: [02:24:00] * eikonos has joined #silverstripe
25: [02:56:00] * LoveDuckie quit (Read error: Connection reset by peer)
26: [03:32:00] * cloph_away has joined #silverstripe
27: [03:33:00] * cloph_away1 quit (Ping timeout: 252 seconds)
28: [04:16:00] * simon_w|air quit (Quit: This computer has gone to sleep)
29: [04:21:00] * spronk has joined #silverstripe
30: [05:13:00] <ss23> I hate concerete5 so much.
31: [05:14:00] * nicolaas quit (Quit: ChatZilla 0.9.90 [Firefox 20.0/20130329030832])
32: [05:24:00] * simon_w|air has joined #silverstripe
33: [06:56:00] * simon_w|air quit (Quit: This computer has gone to sleep)
34: [07:45:00] <kerosene> porque?
35: [07:46:00] <ss23> Can't remember what was annoying me when I said that
36: [07:47:00] <willr> @ss23 http://open.silverstripe.org/query?status=accepted&status=assigned&status=infoneeded&status=infoneeded_new&status=new&status=started&keywords=!~migration-todo&keywords=!~migrate-todo&col=id&col=summary&col=status&col=type&col=priority&col=milestone&col=component&report=132&order=priority
37: [07:47:00] <willr> Woot!
38: [07:48:00] <ss23> nice though, willr :D
39: [07:48:00] <willr> https://github.com/silverstripe/sapphire/issues
40: [07:48:00] <ss23> :P
41: [07:48:00] <ss23> willr: Damit! What are we going to do on the hackfest now!
42: [07:48:00] <willr> ss23 more than enough to keep ya going
43: [07:48:00] <ss23> ahaa
44: [07:49:00] <willr> Got about 80 more to migrate from the last 238 tickets I closed in the last couple days
45: [08:22:00] * pex has joined #silverstripe
46: [08:54:00] * NobrainerWeb has joined #silverstripe
47: [08:57:00] <NobrainerWeb> Hi guys, i need an explanation. I'm trying to create a button like the one from https://github.com/uniun/silverstripe-copybutton but instead of duplicating the record, i wan't to change the relation, moving the record to another page
48: [08:58:00] <NobrainerWeb> But i can't figure out how i get a view for the action - i need somewhere where the user can pick another PageID for the dataobject
49: [08:59:00] <NobrainerWeb> I know that a data object actually has the PageID in the CMS fields, but changing the relation/PageID here does nothing
50: [09:16:00] * priithansen has joined #silverstripe
51: [09:23:00] * priithansen quit (Quit: priithansen)
52: [09:24:00] <simon_w> willr, that system you built is all kinds of broken
53: [09:30:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/c915dcf5e959...cd7fd5556110
54: [09:30:00] <travis-ci> [travis-ci] silverstripe/sapphire#2217 (post-2.4 - cd7fd55 : Sean Harvey): The build has errored.
55: [09:30:00] * travis-ci has joined #silverstripe
56: [09:30:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7095521
57: [09:30:00] * travis-ci has left #silverstripe
58: [09:32:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7095539
59: [09:32:00] <travis-ci> [travis-ci] silverstripe/sapphire#2218 (2.4 - 813749e : Sean Harvey): The build has errored.
60: [09:32:00] <willr> simon_w which one?
61: [09:32:00] * travis-ci has joined #silverstripe
62: [09:32:00] * travis-ci has left #silverstripe
63: [09:32:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/a2394331aff1...813749e909e6
64: [09:32:00] <simon_w> That's from Michael
65: [09:33:00] <willr> It takes like 18 seconds to load a page, 17.5 seconds from the database server
66: [09:33:00] <willr> one of their tech guys is looking into it.
67: [09:33:00] <willr> Oh FGR, well if they put it on a decent server that would help
68: [09:33:00] * zfmf has joined #silverstripe
69: [09:33:00] <simon_w> Yeah, I guesses it was mostly ITS
70: [09:34:00] <willr> Pain, but they don't know what they're doing. If I could self host it would of been live 2 years ago and issue free
71: [09:35:00] <willr> They also can't manage email notifications.
72: [09:48:00] <zfmf> is there a way to add an action to a modeladmin, but not to the gridfielddetailform i want a action near the add ..... button on the main gridfield list
73: [09:50:00] <simon_w> But you make yourself a component and add it to the config
74: [09:50:00] <simon_w> zfmf, have a look at how GridFieldAddNewButton does it
75: [10:04:00] <zfmf> can i add it in getcmsactions or is there another method for adding it to the config
76: [10:09:00] <simon_w> It's part of the grid field, not the GridFieldDetailForm
77: [10:09:00] <simon_w> getEditForm on the ModelAdmin
78: [10:12:00] * Zauberfisch quit (Excess Flood)
79: [10:12:00] * Zauberfisch has joined #silverstripe
80: [10:16:00] * NobrainerWeb quit (Quit: NobrainerWeb)
81: [10:26:00] <zfmf> $form->Fields()->fieldByName($this->sanitiseClassName($this->modelClass))->getConfig()->addComponent(new GridFieldMyButton('test')); but i'm getting: Uncaught LogicException: GridField HTML fragment 'test' was given content, but not defined. Perhaps there is a supporting GridField component you need to add?
82: [10:41:00] * willr quit (Quit: willr)
83: [10:44:00] <simon_w> I'll give you a hint. It's not the name of the button.
84: [10:44:00] <simon_w> zfmf, think about what the 'test' here is
85: [10:46:00] * xyphoid has joined #silverstripe
86: [10:46:00] * xyphoid_ is now known as xyphoid
87: [10:46:00] * xyphoid quit (Changing host)
88: [10:50:00] <zfmf> simon_w: thanks i used buttons-before-right now the button is visible :D
89: [11:02:00] * pex quit (Ping timeout: 264 seconds)
90: [11:06:00] * pex has joined #silverstripe
91: [11:10:00] * osterlaus has joined #silverstripe
92: [11:53:00] * Zauberfisch has joined #silverstripe
93: [11:53:00] <Zauberfisch|idle> I am looking for a best practice example on namespacing the mysite folder
94: [11:56:00] <Zauberfisch> simon_w do you have your mysite folder namespaced?
95: [12:12:00] * priithansen has joined #silverstripe
96: [12:12:00] <ss23> like 200 errors just when running one method
97: [12:12:00] <ss23> >.<
98: [12:12:00] <ss23> holy crap. Turned on error reporting to try debug this concrete5 theme. NEVER AGAIN
99: [12:44:00] * Kolin_ is now known as Kolin
100: [13:08:00] <zfmf> howto set a success or error message after the action is called in modeladmin
101: [13:22:00] * Shrike_Finland has joined #silverstripe
102: [13:37:00] * Shrike_Finland1 has joined #silverstripe
103: [13:41:00] * Shrike_Finland quit (Ping timeout: 276 seconds)
104: [14:01:00] * gelignite has joined #silverstripe
105: [14:23:00] * badmanDOT has joined #silverstripe
106: [14:26:00] * the_Alien has joined #silverstripe
107: [14:26:00] * badmanDOT quit (Quit: ThrashIRC v2.9 sic populo comunicated)
108: [14:28:00] * the_Alien quit (Client Quit)
109: [14:48:00] * osterlaus quit (Quit: Leaving.)
110: [14:49:00] * osterlaus has joined #silverstripe
111: [15:01:00] * pex quit (Ping timeout: 256 seconds)
112: [15:02:00] * osterlaus quit (Quit: Leaving.)
113: [15:06:00] * ImacSS has joined #silverstripe
114: [15:07:00] <ImacSS> Hey all. Running 3.1.0-beta2 and having a problem with getting the CMS to save any type of Time value, using either 'Time' or 'SS_Datetime' data types, with 'TimeField' or 'DatetimeField' form fields respectively. Is there a known bug with these field types?
115: [15:08:00] <ImacSS> Actually, to be more specific - I cannot save times containing 'PM' values
116: [15:09:00] <ImacSS> I enter '21:00' or '9:00pm', and when the form reloads after saying it saved successfully, it displays as '9:00 AM'
117: [15:18:00] * ss-log quit (Ping timeout: 264 seconds)
118: [20:12:00] * ss-log has joined #silverstripe
119: [20:21:00] <simon_w> Sigh. Looking to move ss-log out of HD's DC
120: [20:30:00] <Zauberfisch> HD's DC?
121: [20:31:00] <simon_w> HostingDirect's data centre
122: [20:32:00] <simon_w> I've had to restart it due to dropped connections 5 times in the last 24 hours
123: [20:33:00] <simon_w> The bot, not the data centre
124: [20:36:00] * nickmolhoek quit (Remote host closed the connection)
125: [20:36:00] * nickmolhoek has joined #silverstripe
126: [20:36:00] * nickmolhoek has joined #silverstripe
127: [20:53:00] * Pyromanik has joined #silverstripe
128: [20:56:00] <zfmf1> Zauberfisch: im getting 404 wheni use routes.yml any idea whats wrong? http://sspaste.com/paste/show/519001ebbdc0b
129: [20:58:00] <simon_w> Also, it pays to ask the channel instead of a single person :p
130: [20:58:00] <simon_w> zfmf1, got the CMS module installed and its injecting a route later that overrides that?
131: [20:58:00] * chillu has joined #silverstripe
132: [20:59:00] <Zauberfisch> simon_w got a good point
133: [21:00:00] <Zauberfisch> I would not be writing here now if I didn't got the beep (:
134: [21:00:00] <Zauberfisch> zfmf1 when you open the url in your browser do you call any actions?
135: [21:00:00] <simon_w> Zauberfisch, so did I :p
136: [21:00:00] <Zauberfisch> on the otherhand, simon_w I helped him earlier with just that thing, so it is not wrong to want to highlight me
137: [21:01:00] <Zauberfisch> ah, that's good
138: [21:01:00] <Zauberfisch> you might need to add /$Action/$ID/$Name to your route in the yml file
139: [21:01:00] <simon_w> Nah, and that'll break in 3.1 :p
140: [21:01:00] <Zauberfisch> oh
141: [21:01:00] <simon_w> (you need // in the right place finally)
142: [21:02:00] * unsigned_ is now known as unsignedint
143: [21:03:00] <simon_w> zfmf1, it's likely you've got a rule added later that overrides that one. Use ?debug=1 to see what rules you've got
144: [21:03:00] <Zauberfisch> chillu, man of the hour
145: [21:03:00] <Zauberfisch> yaaaaaaaay
146: [21:03:00] <zfmf1> simon_w: he brought me to use yml files instead of _config so i highlighted him, i'm always asking all of you :D
147: [21:04:00] <zfmf1> hmmm
148: [21:04:00] <Zauberfisch> lolcat works again
149: [21:04:00] <Zauberfisch> !
150: [21:04:00] <chillu> we should put out a beta4 because of it ;)
151: [21:05:00] <simon_w> With the blog post being written entirely in lolcat?
152: [21:05:00] <Zauberfisch> don-t forget to merge the cms fork as well
153: [21:08:00] <chillu> url for cms PR?
154: [21:08:00] <simon_w> chillu, https://github.com/silverstripe/silverstripe-cms/pull/703
155: [21:08:00] <zfmf1> i'm calling the url like this domain.com/checkLicence?Licence=yvydfad must i rewrite this now??? also with /$Action/$ID/$Name im getting 404
156: [21:08:00] <chillu> i've got a million emails at the mo, still going through them
157: [21:10:00] <CJT> Morning all
158: [21:10:00] * CJT has joined #silverstripe
159: [21:11:00] * qlex has left #silverstripe
160: [21:11:00] * qlex has joined #silverstripe
161: [21:11:00] <CJT> Is there a known bug with the latest beta 3 that when clicking on the Home page under the CMS it directs you away from it? Or is it something funny with my install?
162: [21:12:00] * qlex has joined #silverstripe
163: [21:13:00] <CJT> so my url goes from ../pages/edit/show/1 and jumps straight to ../page/edit/show/4 (page no found)
164: [21:13:00] <CJT> in the editor...
165: [21:13:00] <CJT> yeah only happens with home, takes me to page not found
166: [21:13:00] <simon_w> CJT, haven't heard of that happening. Does it only happen with Home? And where does it take you to?
167: [21:14:00] <simon_w> Got anything funky in your home page's class?
168: [21:14:00] <CJT> nope, its just the default install
169: [21:14:00] <CJT> about us, contact us, etc etc are all fine though
170: [21:15:00] <CJT> Failed to load resource: the server responded with a status of 404 (Not Found)
171: [21:15:00] <CJT> ...should have looked there first
172: [21:15:00] <simon_w> Getting any errors in your JS console?
173: [21:16:00] * travis-ci has left #silverstripe
174: [21:16:00] * qlex quit (Ping timeout: 248 seconds)
175: [21:16:00] <simon_w> Could someone have deleted the page without you realising?
176: [21:16:00] * travis-ci has joined #silverstripe
177: [21:16:00] <travis-ci> [travis-ci] silverstripe/sapphire#2219 (3.1 - 9540b7d : Ingo Schommer): The build has errored.
178: [21:16:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/0f7a5d29c831...9540b7dca672
179: [21:16:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7107140
180: [21:17:00] <CJT> Na, its on my local dev server - The page views just fine normally its only when trying to edit it in the CMS that I'm getting bounced off it
181: [21:17:00] <Zauberfisch> thanks chillu
182: [21:18:00] <CJT> If its not a known issue I'll just wipe out the install and start again
183: [21:20:00] <simon_w> Well, it's certainly not a known issue and I've never seen something like it before
184: [21:21:00] <travis-ci> [travis-ci] silverstripe/silverstripe-cms#364 (3.1 - f0e7990 : Ingo Schommer): The build passed.
185: [21:21:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/silverstripe-cms/builds/7107255
186: [21:21:00] * travis-ci has left #silverstripe
187: [21:21:00] * travis-ci has joined #silverstripe
188: [21:21:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/silverstripe-cms/compare/7c68414fe751...f0e7990ca357
189: [21:27:00] * travis-ci has joined #silverstripe
190: [21:27:00] * travis-ci has left #silverstripe
191: [21:27:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7107301
192: [21:27:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/9540b7dca672...e135421ac883
193: [21:27:00] <travis-ci> [travis-ci] silverstripe/sapphire#2220 (3.1 - e135421 : Ingo Schommer): The build passed.
194: [21:29:00] <CJT> It seems to be a issue with priithansens foundation javascript implementation and nothing to do with ss
195: [21:30:00] * FireMe quit (Remote host closed the connection)
196: [21:32:00] * travis-ci has left #silverstripe
197: [21:32:00] * travis-ci has joined #silverstripe
198: [21:32:00] <travis-ci> [travis-ci] silverstripe/sapphire#2221 (3.1 - 46bc588 : Ingo Schommer): The build passed.
199: [21:32:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/e135421ac883...46bc588a1b67
200: [21:32:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7107316
201: [21:34:00] * SightUnseen has joined #silverstripe
202: [21:35:00] * DigNZ has joined #silverstripe
203: [21:35:00] * DigNZ has joined #silverstripe
204: [21:35:00] * DigNZ quit (Remote host closed the connection)
205: [21:38:00] * SightUnseen has left #silverstripe
206: [21:40:00] * travis-ci has left #silverstripe
207: [21:40:00] <travis-ci> [travis-ci] silverstripe/sapphire#2222 (3.1 - 8c9dd02 : Ingo Schommer): The build passed.
208: [21:40:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/46bc588a1b67...8c9dd02d738a
209: [21:40:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7107555
210: [21:40:00] * travis-ci has joined #silverstripe
211: [21:43:00] <CJT> alright I'm back again
212: [21:44:00] <CJT> "Viewport argument value "0;" for key "user-scalable" was truncated to its numeric prefix. Note that ';' is not a separator in viewport values. The list should be comma-separated. "
213: [21:44:00] <CJT> clean install of 3.1beta and same problem but new error
214: [21:46:00] <simon_w> Yeah, that's just a warning about meta viewport. It's fine
215: [21:47:00] <CJT> hmm
216: [22:02:00] <CJT> just reinstalled 3.0.5 and everything works as expected
217: [22:02:00] <CJT> so def something funny going on with the latest beta
218: [22:27:00] <Zauberfisch> pong
219: [22:27:00] <chillu> Zauberfisch: *ping* :)
220: [22:28:00] <Zauberfisch> ah, I see
221: [22:29:00] * willr has joined #silverstripe
222: [22:29:00] * zfmf1 has left #silverstripe
223: [22:32:00] <MiniZeka> hello
224: [22:32:00] * MiniZeka has joined #silverstripe
225: [22:32:00] * travis-ci has joined #silverstripe
226: [22:32:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/8c9dd02d738a...8c02f10c0364
227: [22:32:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7108496
228: [22:32:00] * travis-ci has left #silverstripe
229: [22:32:00] <travis-ci> [travis-ci] silverstripe/sapphire#2223 (3.1 - 8c02f10 : Ingo Schommer): The build passed.
230: [22:32:00] <Pyromanik> hi
231: [22:33:00] <Pyromanik> probably doesn't check it, or it's not returning what you expect.
232: [22:33:00] <MiniZeka> why does public function canCreate doesn't affect button "Add new ModelName" in admin?
233: [22:34:00] <MiniZeka> return false;
234: [22:34:00] <Pyromanik> then it must be former
235: [22:34:00] <MiniZeka> can't be second option
236: [22:34:00] <MiniZeka> since it's one liner
237: [22:34:00] <MiniZeka> yup
238: [22:35:00] <MiniZeka> is that a bug? and
239: [22:35:00] <MiniZeka> how can I fix it?
240: [22:35:00] <MiniZeka> in that case - I have 2 questions
241: [22:36:00] <Pyromanik> MiniZeka: I'm not an architect, probably best to ask chillu or simon_w
242: [22:39:00] <travis-ci> [travis-ci] Build details : http://travis-ci.org/silverstripe/sapphire/builds/7108558
243: [22:39:00] * travis-ci has joined #silverstripe
244: [22:39:00] <travis-ci> [travis-ci] silverstripe/sapphire#2225 (3.1 - fd1aa19 : Sean Harvey): The build passed.
245: [22:39:00] <travis-ci> [travis-ci] Change view : https://github.com/silverstripe/sapphire/compare/8c02f10c0364...fd1aa197d5f3
246: [22:39:00] * travis-ci has left #silverstripe
247: [22:40:00] <simon_w> MiniZeka, it does use canCreate() on a singleton of the model
248: [22:43:00] <MiniZeka> are you sure? because all I have in that method is canCreate($member = null) { return false; }
249: [22:44:00] <simon_w> https://github.com/silverstripe/sapphire/blob/3.1/forms/gridfield/GridFieldAddNewButton.php#L26
250: [22:44:00] <simon_w> yup
251: [22:45:00] <MiniZeka> in 3.1 maybe
252: [22:46:00] <MiniZeka> in 3.0.5 http://sspaste.com/paste/show/51901b9b925e2
253: [22:54:00] <K2> got another one now - the content HTML editor box in the admin CMS is showing blank
254: [22:54:00] * K2 has joined #silverstripe
255: [22:54:00] <K2> hey team
256: [22:54:00] <K2> thanks for your help last week
257: [22:55:00] <K2> read something online that this could be related to the .htaccess file
258: [22:55:00] <K2> any ideas?
259: [23:00:00] * MiniZeka quit (Ping timeout: 245 seconds)
260: [23:11:00] <Pyromanik> check js console for errors?
261: [23:11:00] <Pyromanik> K2: update?
262: [23:12:00] <K2> no errors or anything like that
263: [23:14:00] * EasyCo has joined #silverstripe
264: [23:15:00] <Pyromanik> even in network tab?
265: [23:17:00] <EasyCo> FrozenFire: You kicking around?
266: [23:20:00] <Pyromanik> EasyCo: ask question!
267: [23:22:00] <EasyCo> If you insist. He mentioned that he managed to use translatable to work with custom DataObjects. I was wondering what he needed to do.
268: [23:24:00] <K2> @Pyromanik - yeah nothing in network tab
269: [23:25:00] <Pyromanik> do TinyMCE.init() or whatever that code is
270: [23:25:00] <Pyromanik> K2: should be something. You're loading the page, it then loads all JS, and inits the fields
271: [23:25:00] <Pyromanik> if it works
272: [23:25:00] <Pyromanik> soemthing def. going wrong
273: [23:25:00] <Pyromanik> if it doesn't, then file probably isn't loading and you've gotta do the .htaccess fix
274: [23:26:00] <Pyromanik> simon_w: if I add $allowed_children to a decorator, then apply it to a site tree, will it work?
275: [23:26:00] <Pyromanik> add a static*
276: [23:26:00] <K2> what's the .htaccess fix?
277: [23:28:00] * chillu quit (Quit: chillu)
278: [23:30:00] <Pyromanik> stink :<
279: [23:30:00] <simon_w> Doesn't look like it
280: [23:31:00] * joelpittet has joined #silverstripe
281: [23:32:00] * howardgrigg has joined #silverstripe
282: [23:37:00] <simon_w> Woo, moving ss-log onto a more stable host
283: [23:44:00] <willr> simon_w not Rimu?
284: [23:44:00] <simon_w> willr, moving to site host
285: [23:44:00] <willr> AWS!
286: [23:45:00] <simon_w> Or not :p
287: [23:47:00] <willr> probably be cheaper, unless you're sharing machines
288: [23:52:00] <simon_w> Bye bye ss-log!

These logs were automatically created by ss-log on irc.freenode.net.