#silverstripe IRC Log

IRC log for 28 April 2013

All timestamps are in UTC.

1: [00:23:00] * SightUnseen1 has left #silverstripe
2: [01:01:00] <Extro> when i try upload images to ss, this happens: http://screencloud.net/v/lAXP
3: [01:19:00] * gelignite quit (Quit: http://bit.ly/nkczDT)
4: [01:27:00] * Emil_Blume has left #silverstripe
5: [02:10:00] <Zauberfisch> Extro the error message is cut of
6: [02:10:00] <Zauberfisch> display the full one
7: [02:11:00] <Zauberfisch> also, what ss version?
8: [02:44:00] * timsnadden_ has joined #silverstripe
9: [03:00:00] * OldTom has joined #silverstripe
10: [03:02:00] * timsnadden_ quit (Quit: timsnadden_)
11: [03:30:00] * Bollig|DesignCty has joined #silverstripe
12: [03:40:00] * Bollig|DesignCty quit (Quit: Bollig|DesignCty)
13: [03:48:00] * cloph_away has joined #silverstripe
14: [03:49:00] * wmk has joined #silverstripe
15: [03:49:00] * cloph_away1 quit (Ping timeout: 252 seconds)
16: [03:59:00] * wmk quit (Ping timeout: 256 seconds)
17: [04:33:00] * maknz quit (Quit: ["Textual IRC Client: www.textualapp.com"])
18: [04:41:00] <Extro> Zauberfisch latest ss
19: [04:42:00] <Zauberfisch> latest stable or latest dev?
20: [04:42:00] <Extro> stable
21: [04:42:00] <Zauberfisch> if dev which branch?
22: [04:42:00] <Zauberfisch> have you tried dev?
23: [04:42:00] <Zauberfisch> go fetch the 3.1 branch
24: [04:42:00] <Extro> whys that ?
25: [04:42:00] <Zauberfisch> because 3.0.5 is so 2 weeks ago :P
26: [04:43:00] <Extro> lol
27: [04:43:00] <Extro> when i try upload images to ss, this happens: http://screencloud.net/v/lAXP
28: [04:43:00] <simon_w> Though you should grab 3.0, not 3.1
29: [04:43:00] <simon_w> I'm counting two months :p
30: [04:44:00] <Extro> simion know how to fix ? lol
31: [04:44:00] <simon_w> Know how to get the actual error message?
32: [04:44:00] <Zauberfisch> simon_w why recommend 3.0 over 3.1?
33: [04:44:00] * DesignerX has joined #silverstripe
34: [04:44:00] <Zauberfisch> ohai DesignerX
35: [04:44:00] <simon_w> Zauberfisch, upgrade pains. Seriously, the upgrade to 3.1 is probably going to be more annoying than to 3.0
36: [04:44:00] <DesignerX> hi :D
37: [04:45:00] <Extro> hi designer
38: [04:45:00] <Extro> i have a problem ;3
39: [04:45:00] <Extro> http://screencloud.net/v/lAXP
40: [04:45:00] <simon_w> Extro, yeah, we know, Now, get the actual error message :p
41: [04:45:00] <Extro> where from lol
42: [04:45:00] <Zauberfisch> tryed saying that 2 hours ago :P
43: [04:45:00] <simon_w> error log, browser's console looking at the server's response
44: [04:46:00] <Zauberfisch> Extro don't bother asking other people, if simon_w can't help you, chances are no one else can
45: [04:46:00] <Extro> XD
46: [04:46:00] <Zauberfisch> I am being serious
47: [04:46:00] <DesignerX> Extro: hi, what is the error ?
48: [04:46:00] <Extro> ailed to load resource: the server responded with a status of 500 (Warning at line 161 of /home/inversc/public_html/silverstripe/framework/filesystem/Upload.php)
49: [04:46:00] <Extro> 500 internal error
50: [04:46:00] <Extro> im guessing
51: [04:47:00] <Extro> eres a screenshot of le errors http://screencloud.net/v/szs1
52: [04:47:00] <Zauberfisch> Extro good, and now find the stack trace
53: [04:47:00] <simon_w> Extro, look at the body of the response
54: [04:47:00] <simon_w> (usually by clicking on it)
55: [04:47:00] <Extro> http://silverstripe.invers.co.nz/admin/pages/EditorToolbar/MediaForm/field/AssetUploadField/upload
56: [04:47:00] <DesignerX> Extro: I use firebug & use the Net tab to see any error messages, you will see it in red text
57: [04:48:00] <Zauberfisch> Extro most likely error cause on line 161 would be file permissions
58: [04:48:00] <Extro> been having a lot of them lately
59: [04:49:00] <Zauberfisch> ensure assets dir is writeable
60: [04:49:00] <Extro> http://screencloud.net/v/n4kA
61: [04:50:00] <Zauberfisch> and if that does not help, my next guess goes to weird server config
62: [04:50:00] <Zauberfisch> make that 777 just to be sure
63: [04:51:00] <Zauberfisch> its array key not defined
64: [04:51:00] <Zauberfisch> hmm
65: [04:51:00] <Zauberfisch> so its not permissions
66: [04:51:00] <Zauberfisch> they would generate an error
67: [04:51:00] <Zauberfisch> but actually, no, file permissions would not generate a warning
68: [04:51:00] <Extro> it is an error
69: [04:52:00] <Zauberfisch> DesignerX 3.0
70: [04:52:00] <Zauberfisch> not judging from your response message
71: [04:52:00] <DesignerX> Extro: is that SS 3.1 ?
72: [04:52:00] <Zauberfisch> latest stable
73: [04:53:00] <Zauberfisch> 1) file permission issues in the /tmp folder, therefore the upload does not work
74: [04:53:00] <Zauberfisch> I am guessing:
75: [04:53:00] <Zauberfisch> its either
76: [04:53:00] <DesignerX> Zauberfisch: I dont remember seeing the file upload windoes like that with tabs ?@
77: [04:54:00] <Extro> alright
78: [04:54:00] <Zauberfisch> 2) some bug with upload, or actually with assetadmin using upload
79: [04:54:00] <Extro> and now it worked
80: [04:54:00] <Extro> changed uploads folder to 777
81: [04:54:00] <Zauberfisch> DesignerX I do
82: [04:55:00] <Zauberfisch> HTMLEditorField, hmmm, not really my domain
83: [04:55:00] <Extro> but an error still showed
84: [04:55:00] <Extro> http://screencloud.net/v/8NFy
85: [04:56:00] <Zauberfisch> Extro when does that error show up?
86: [04:57:00] <Zauberfisch> Extro just to be sure, try loging out and in again in the CMS
87: [04:57:00] <Zauberfisch> and try again
88: [04:58:00] <Extro> wait nvm
89: [04:58:00] <Zauberfisch> could be a session thing or so, not sure how the upload is hacked into the html editor
90: [04:58:00] <Extro> error doesnt show lol
91: [04:58:00] <Zauberfisch> Extro then fix your webserver
92: [04:58:00] <Extro> but its bad having a folder 777 permissions :(
93: [04:58:00] <Extro> whats wrong with it lol
94: [04:59:00] <Zauberfisch> my assumption is that your web server user is neither owner nor in the group owning your files
95: [04:59:00] <Extro> same lol
96: [04:59:00] <Zauberfisch> thus you need 777
97: [04:59:00] <Zauberfisch> Extro assets on 777 ... well, I have seen worse
98: [04:59:00] <Zauberfisch> and done worse
99: [05:03:00] * sewid has joined #silverstripe
100: [05:04:00] <Extro> why did ss tell me to set folders permissions to noone
101: [05:20:00] <DesignerX> #linux
102: [05:25:00] * robert_ has joined #silverstripe
103: [05:54:00] * Kapdap has joined #silverstripe
104: [05:58:00] * maknz has joined #silverstripe
105: [05:58:00] * maknz quit (Changing host)
106: [05:58:00] * maknz has joined #silverstripe
107: [06:05:00] * timsnadden has joined #silverstripe
108: [06:17:00] <simon_w> Extro, because that's the user the web server runs as, and it needs to be able to write to the folder
109: [06:18:00] * maknz quit (Read error: Connection reset by peer)
110: [06:30:00] * robert_ has left #silverstripe
111: [06:32:00] <OldTom> unless it's www-data
112: [06:36:00] <simon_w> OldTom, then SilverStripe will tell you to change it to www-data
113: [06:37:00] <OldTom> cool
114: [07:03:00] * timsnadden quit (Quit: timsnadden)
115: [07:43:00] <DesignerX> hi guys, abyone here can help a bit with SQL ?
116: [07:43:00] <DesignerX> anyone *
117: [07:44:00] <DesignerX> hi, I need help with SQl, I have create a backup of a database but now I cant use that db with MySQL :(
118: [07:44:00] <ss23> if you ask us the question, maybe
119: [07:44:00] <ss23> But otherwise, try #mindreading
120: [07:45:00] <DesignerX> ss23: lol :D
121: [07:45:00] <DesignerX> i egt some syntax error , I wm pating the code right now..
122: [07:46:00] <DesignerX> http://www.sspaste.com/paste/show/517cd3c3ab5dd
123: [07:46:00] <DesignerX> the error & the SQL code I have ..
124: [07:47:00] <ss23> that SQL makes no sense
125: [07:47:00] <ss23> uh
126: [07:48:00] <ss23> are you missing a ;
127: [07:48:00] <ss23> insert into customer stuff; create table?
128: [07:49:00] <DesignerX> line 61 ?
129: [07:51:00] <ss23> line 008 of that paste
130: [07:53:00] <DesignerX> I will check
131: [07:54:00] <DesignerX> ss23: worked like... MAGIC :D
132: [07:54:00] <DesignerX> ty
133: [07:55:00] <ss23> np
134: [07:55:00] <ss23> :D
135: [09:00:00] * Kay2 has joined #silverstripe
136: [09:03:00] <Kay2> Deprecated: Priority argument is now ignored - use the default of 100. You should really be setting routes via _config yaml fragments though. Called from . in /opt/bitnami/apache2/groove/framework/dev/Deprecation.php on line 173
137: [09:03:00] <Kay2> hey guys - any idea what would be causing this error?
138: [09:07:00] * DesignerX quit (Ping timeout: 240 seconds)
139: [09:08:00] * DesignerX has joined #silverstripe
140: [09:09:00] <simon_w> Kay2, either one of your modules or your code is using Director::add_rules()
141: [09:12:00] <Kay2> awesome thanks!
142: [09:18:00] * willmorgan has joined #silverstripe
143: [09:38:00] * willmorgan quit (Ping timeout: 245 seconds)
144: [09:51:00] * osterlaus has joined #silverstripe
145: [09:52:00] <Kay2> error
146: [09:52:00] <Kay2> no dice on the Deprecated: Priority argument is now ignored - use the default of 100. You should really be setting routes via _config yaml fragments though. Called from . in /opt/bitnami/apache2/groove/framework/dev/Deprecation.php on line 173
147: [09:52:00] <Kay2> howdy again
148: [09:53:00] <Kay2> couldnt find any Director::add_rules() in my code...
149: [10:00:00] <simon_w> It's Director::addRules()
150: [10:00:00] <simon_w> Bah, stupid inconsistent naming
151: [10:01:00] <simon_w> And it'll probably be in a _config.php file
152: [10:02:00] * henkpoley has joined #silverstripe
153: [10:09:00] * MattSS_ is now known as MattSS
154: [10:09:00] <Kay2> cheers :)
155: [10:09:00] * willmorgan has joined #silverstripe
156: [10:13:00] * MattSS has joined #silverstripe
157: [10:13:00] * MattSS quit (Changing host)
158: [10:19:00] <simon_w> Whoa, MattSS changed his nick or somesuch
159: [10:24:00] * Kay2 quit (Ping timeout: 245 seconds)
160: [10:53:00] * dangerdan has joined #silverstripe
161: [10:54:00] <dangerdan> how do you get SS to minify your css & js? the internet says use combine_files, but i am doing and all it is doing is just joining the files up, there isnt any minifying going on
162: [10:56:00] * priithansen has joined #silverstripe
163: [11:06:00] <Zauberfisch> dangerdan there is no built in minify
164: [11:06:00] <Zauberfisch> just joining files
165: [11:07:00] <Zauberfisch> but I am personally not to conserned about minifying, libs like jquery are minifiyed anyway,
166: [11:07:00] <Zauberfisch> and for the couple of hundred lines that we write our self's on an average website, doesn't change a thing if its minifyed
167: [11:24:00] * henkpoley quit (Quit: henkpoley)
168: [11:30:00] * Zauberfisch|idle quit (Ping timeout: 256 seconds)
169: [11:37:00] <willmorgan> dangerdan: if you combine JS files, then JSmin is used
170: [11:38:00] <dangerdan> ah it has minified my js
171: [11:38:00] <willmorgan> not so for CSS, though
172: [11:38:00] <dangerdan> thats all good then (y)
173: [11:42:00] * henkpoley has joined #silverstripe
174: [11:44:00] * Zauberfisch|idle has joined #silverstripe
175: [11:45:00] * gelignite has joined #silverstripe
176: [12:52:00] * jghedsa has joined #silverstripe
177: [12:52:00] <jghedsa> goodday
178: [12:53:00] <jghedsa> what is the ss3 equivalent of <% if inGroup(x) %> ?
179: [12:56:00] * henkpoley quit (Quit: henkpoley)
180: [12:58:00] <osterlaus> jghedsa, that depends on your model
181: [12:58:00] * OldTom quit (Quit: leaving)
182: [12:59:00] <osterlaus> the current dataobject might have a function called inGroup or not
183: [12:59:00] <jghedsa> should I make a controller for it myself?
184: [13:00:00] <osterlaus> but only you know that ;) i don't think you need your own controller for this. give us some more hints about your code
185: [13:21:00] * OldTom has joined #silverstripe
186: [13:22:00] * dangerdan quit (Ping timeout: 245 seconds)
187: [13:31:00] * priithansen quit (Quit: priithansen)
188: [13:36:00] <willmorgan> about validation in the CMS
189: [13:36:00] <willmorgan> need a bit of advice - think i've found the cause
190: [13:36:00] <willmorgan> i'm in the middle of fixing an issue on github
191: [13:36:00] <willmorgan> hey
192: [13:37:00] <willmorgan> cc: MattSS simon_w
193: [13:39:00] * priithansen has joined #silverstripe
194: [13:44:00] <willmorgan> https://github.com/silverstripe/sapphire/issues/1777
195: [13:49:00] * DesignerX quit (Ping timeout: 256 seconds)
196: [14:22:00] * sewid quit (Quit: My MacBook Pro has gone to sleep. ZZZzzz???)
197: [14:24:00] <willmorgan> think I've got it, dw
198: [14:57:00] <willmorgan> fixed :)
199: [15:55:00] <Marvanni> I have a GridField with FormAction with addExtraClass('no-ajax') that generates and returns a file (like the csvexport button), but it still submits with ajax
200: [15:59:00] <Marvanni> hm.. the Action is not inside .ss-gridfield fieldset..
201: [16:09:00] * sewid has joined #silverstripe
202: [16:24:00] * OldTom quit (Quit: sleepage)
203: [16:34:00] * osterlaus quit (Quit: Leaving.)
204: [16:41:00] <Marvanni> Any ideas to make no-ajax work on the FromActions on the DetailFroms?
205: [16:56:00] * jcwacky has joined #silverstripe
206: [16:57:00] <jcwacky> In SS3, do styles for TinyMCE no longer need to be inside ".typography"?
207: [16:59:00] <willmorgan> jcwacky: it helps
208: [16:59:00] <jcwacky> in what way?
209: [16:59:00] <willmorgan> that's the existing convention, though you can work against it...
210: [16:59:00] <jcwacky> I'm trying to create a Zurb Foundation 4 SS3 theme.
211: [17:00:00] <jcwacky> and have just noticed that if they are in editor.css but not within .typography it works perfectly, as it appears editor.css is now used as a TinyMCE "theme".
212: [17:00:00] <willmorgan> ah, cool
213: [17:00:00] <willmorgan> well, you can take two approaches:
214: [17:00:00] <willmorgan> yes, exactly
215: [17:00:00] <jcwacky> rather than just being included with the CMS.
216: [17:01:00] <willmorgan> tinymce always asks for editor.css, and you can basically change whatever is in that file - if you want to include typography.css or another file, then so be it
217: [17:01:00] <willmorgan> well, editor.css has historically done @import 'typography.css';
218: [17:02:00] <jcwacky> cool
219: [17:02:00] <willmorgan> h1
220: [17:02:00] <willmorgan> instead of .typography h1
221: [17:02:00] <willmorgan> but generally when writing CSS myself, i find actually namespacing content editor styles to save a lot of headaches
222: [17:02:00] <jcwacky> cool, so no need at all for ".typography" anymore?
223: [17:02:00] <willmorgan> so it could contain some generic styles, like
224: [17:03:00] <willmorgan> there's never been a need for it as far as i can remember, it's just convention
225: [17:04:00] <jcwacky> I thought before (in 2.4) if you said p{color:red} instead of .typography p{color:red}, then parts of the CMS would get turn red too?
226: [17:04:00] <willmorgan> ahh yes, you're right
227: [17:05:00] <willmorgan> sorry!
228: [17:06:00] <willmorgan> the only reason that happens is because editor.css was included
229: [17:06:00] <jcwacky> http://spdr.me/JX5T
230: [17:06:00] <willmorgan> let me check
231: [17:07:00] <jcwacky> Doesn't appear to be the case in SS3 anymore though.
232: [17:08:00] <willmorgan> yeah i've double checked
233: [17:08:00] <willmorgan> while editor.css is included, it's included by setting it as a tinymce option
234: [17:08:00] <willmorgan> sorry for the confusion there
235: [17:09:00] <jcwacky> no probe, I've just compared 2.4 to 3
236: [17:10:00] <willmorgan> yeah, that makes sense
237: [17:10:00] <jcwacky> in 3 it doesn't look like typography is included anymore
238: [17:10:00] <jcwacky> in 2.4 editor.css was still included that way as a TinyMCE option
239: [17:10:00] <jcwacky> but typography.css was also included as a standard stylesheet link
240: [17:10:00] <willmorgan> is it put in to the iframe or?
241: [17:11:00] <jcwacky> cheers!
242: [17:11:00] <jcwacky> great! I'll continue making my Foundation 4 theme then!
243: [17:13:00] <willmorgan> gl :)
244: [17:20:00] * osterlaus has joined #silverstripe
245: [17:21:00] * osterlaus quit (Client Quit)
246: [18:20:00] * peter_ss has joined #silverstripe
247: [18:20:00] * peter_ss has left #silverstripe
248: [18:24:00] <sewid> I have the "normal" content field and a right and a left sidebar field
249: [18:24:00] <sewid> Hi there!
250: [18:24:00] <sewid> I am looking for a working tutorial to extend the frontend search to search in custom fields
251: [18:25:00] <sewid> How do I get the search to search in these fields?
252: [18:39:00] <willmorgan> add them to your search context
253: [18:39:00] <willmorgan> which version?
254: [18:40:00] <sewid> I've added this to my _config.php: Page::add_extension("FulltextSearchable('RightSidebar,LeftSidebar')");
255: [18:40:00] <sewid> 3.1
256: [18:41:00] <willmorgan> read the link above ^ the description at the top
257: [18:41:00] <willmorgan> right
258: [18:41:00] <willmorgan> http://api.silverstripe.org/3.1/class-SearchContext.html
259: [18:41:00] <sewid> But it seems, that the frontend search is hardcoded and only File and SiteTree is searched
260: [18:41:00] <sewid> Now I am looking for a working tutorial to build a custom frontend search with 3.1
261: [18:41:00] <willmorgan> just add them to your $searchable_fields
262: [18:41:00] <sewid> All tutorials I found won't work :-(
263: [18:41:00] <sewid> Really?
264: [18:42:00] <sewid> ?
265: [18:42:00] <willmorgan> add the field names to your $searchable_fields
266: [18:42:00] <sewid> That should work with the frontend search?!
267: [18:42:00] <sewid> I thought I already tried that (I am trying to solve this problem for hours)
268: [18:42:00] <willmorgan> let me check. haven't done custom search in 3.1 yet
269: [18:42:00] <sewid> $searchable_fields like that (in Page class): public static $searchable_fields = array( 'LeftSidebar', 'RightSidebar' );
270: [18:43:00] <sewid> re-tried it - it's not working with $searchable_fields added
271: [18:44:00] <sewid> It is searching in Content and Title (even when not added)
272: [18:44:00] <willmorgan> also your Content and Title fields
273: [18:44:00] <sewid> It seems to ignore this setting
274: [18:45:00] <sewid> I am reading for hours ;-)
275: [18:45:00] <willmorgan> hmm
276: [18:45:00] <willmorgan> time to read the source, luke :-P
277: [18:45:00] <willmorgan> are you using this class?
278: [18:45:00] <willmorgan> http://api.silverstripe.org/3.1/class-SearchForm.html
279: [18:45:00] * jghedsa quit (Ping timeout: 245 seconds)
280: [18:46:00] <sewid> MySQLDatabase class has this method searchEngine()
281: [18:46:00] <sewid> SearchForm has a method getResults()
282: [18:46:00] <sewid> This method calls DB::getConn()->searchEngine(
283: [18:47:00] <willmorgan> pretty sure i've done this before
284: [18:47:00] <sewid> And there, everything is hardcoded
285: [18:47:00] <willmorgan> hmm
286: [18:49:00] <sewid> Pleeeeease let me know how
287: [18:49:00] <willmorgan> like, we definitely used searchcontexts
288: [18:50:00] <willmorgan> that's the guide we used
289: [18:50:00] <willmorgan> sewid: did you try this? http://doc.silverstripe.org/framework/en/reference/searchcontext
290: [18:51:00] <sewid> I will try that, thanks
291: [18:51:00] <sewid> no, not yet
292: [18:51:00] <willmorgan> sorry - i'm not at work where all that code is, but i'm pretty sure we used that guide and we got it working
293: [18:52:00] <willmorgan> if it's just adding extra DB fields to a flat model, then it should be quite straightforward
294: [18:52:00] <willmorgan> the documentation was a little bit hazy in some places but it seems to have improved somewhat
295: [18:52:00] <willmorgan> we were doing lots of joins and ran in to some SQL parser/builder errors
296: [18:53:00] <sewid> ok, thanks for your help
297: [18:54:00] <sewid> Let's hope I can get it to work
298: [19:09:00] <MiniZeka> Hi everyone!
299: [19:09:00] * MiniZeka has joined #silverstripe
300: [19:09:00] <willmorgan> howdy
301: [19:10:00] <MiniZeka> how?
302: [19:10:00] <MiniZeka> I was wondering, is it possible to change text on add new button ("Add $ModelName")?
303: [19:10:00] <willmorgan> yes
304: [19:10:00] <willmorgan> set $singular_name as a static on your dataobject
305: [19:11:00] <willmorgan> private static $singular_name = 'Name of thing to add';
306: [19:11:00] <MiniZeka> (facepalm)
307: [19:11:00] <willmorgan> is that what you needed?
308: [19:11:00] <MiniZeka> I used that $singular_name so many times, and yet I couldn't come up with that idea
309: [19:12:00] <MiniZeka> thank you willmorgan !
310: [19:12:00] <willmorgan> ha!
311: [19:12:00] <MiniZeka> yes, that's exactly what I needed :)
312: [19:17:00] * timsnadden has joined #silverstripe
313: [19:27:00] * jcwacky quit (Quit: jcwacky)
314: [19:27:00] <willmorgan> you're welcome
315: [19:27:00] <willmorgan> hopefully the rest of the project goes well too
316: [19:31:00] <sewid> I have a working version of SearchContext (thanks!), but I have an input field for every database field
317: [19:31:00] <sewid> willmorgan, one more question to SearchContext
318: [19:31:00] <sewid> Is it possible to have only one input field to let the SearchContext search in many fields (e.g. Content, Right Sidebar, Left Sidebar)?
319: [19:32:00] <sewid> Do you know that?
320: [19:48:00] <willmorgan> hmm, yeah
321: [19:48:00] <willmorgan> erm
322: [19:48:00] <willmorgan> that's a good one
323: [19:49:00] <willmorgan> but i don't know how
324: [19:49:00] <willmorgan> not to my knowledge i'm afraid mate
325: [19:49:00] <sewid> hm, that's bad
326: [19:49:00] <willmorgan> i'm sure it's possible
327: [19:50:00] <willmorgan> you might need to construct the search context using lots of or filters
328: [19:53:00] <MiniZeka> sewid I can confirm it's possible
329: [19:54:00] <MiniZeka> and I wont be there for next 11 hours
330: [19:54:00] <sewid> Do you maybe have some example code for that?
331: [19:54:00] <MiniZeka> yes, but in the office :(
332: [19:55:00] <sewid> MiniZeka, can you send me some code tomorrow by mail?
333: [19:56:00] <sewid> that would be great
334: [19:56:00] <MiniZeka> let me check if I can reach it now
335: [20:01:00] <MiniZeka> nope, FW is rejecting my home IP
336: [20:13:00] * spronk has joined #silverstripe
337: [20:19:00] * mobiusnz has joined #silverstripe
338: [20:29:00] * lenix- has joined #silverstripe
339: [20:31:00] <MiniZeka> it turned out that solution to sewid's problem is http://sspaste.com/paste/show/517d84783fe56 with some small modifications which he'll wrote in comment of sspaste
340: [20:31:00] * Zauberfisch|idle quit (Read error: Connection reset by peer)
341: [20:31:00] * lenix quit (Ping timeout: 245 seconds)
342: [20:32:00] * Zauberfisch|idle has joined #silverstripe
343: [20:34:00] * MiniZeka_ has joined #silverstripe
344: [20:37:00] * Rojod quit (Read error: Connection reset by peer)
345: [20:37:00] * MiniZeka quit (Ping timeout: 245 seconds)
346: [20:38:00] * MiniZeka_ is now known as MiniZeka
347: [20:38:00] * Rojod has joined #silverstripe
348: [20:45:00] * SightUnseen has left #silverstripe
349: [20:45:00] * SightUnseen has joined #silverstripe
350: [21:04:00] * timsnadden quit (Ping timeout: 256 seconds)
351: [21:12:00] * willr_ has joined #silverstripe
352: [21:21:00] * timsnadden has joined #silverstripe
353: [21:22:00] * osterlaus has joined #silverstripe
354: [21:22:00] * MiniZeka quit (Ping timeout: 245 seconds)
355: [21:24:00] * chillu has joined #silverstripe
356: [21:25:00] * sewid quit (Quit: Textual IRC Client: www.textualapp.com)
357: [21:25:00] * timsnadden quit (Client Quit)
358: [21:28:00] * timsnadden_ has joined #silverstripe
359: [21:31:00] * willmorgan has left #silverstripe
360: [21:35:00] * Pyromanik has joined #silverstripe
361: [22:18:00] <unsignedint> Quick question, can anyone tell me what the supported version of PHP is for running Silverstripe 2.4? I just inherited a legacy site and theres way too many issues trying to run it on PHP 5.4
362: [22:20:00] <simon_w> 5.4 support was added in a later version of 2.4 than you're running
363: [22:35:00] <unsignedint> however, I got it via composer and it creates a 'framework' directory which breaks things hardcoded to look at the sapphire directory
364: [22:35:00] <unsignedint> Understood, I just grabbed 2.4.10
365: [22:36:00] <unsignedint> how can I make composer put it in a 'sapphire' directory instead?
366: [22:37:00] <unsignedint> (eg LeftAndMain.php looks for the version via "file_get_contents(BASE_PATH . '/sapphire/silverstripe_version')" so its the core code doing it otherwise id just change my code)
367: [22:38:00] <simon_w> You can't
368: [22:38:00] <simon_w> Rename the folder
369: [22:38:00] <unsignedint> but that will break 'composer update'?
370: [22:38:00] <unsignedint> Actually, ill just symlink it
371: [22:40:00] <unsignedint> nope that doesnt work because Silverstripe tries to include all the classes twice
372: [22:43:00] <unsignedint> how come 2.4 is included on packagist.org if it cant be installed via composer and work?
373: [22:44:00] <simon_w> Because it's a branch that exists
374: [22:46:00] <simon_w> You could try adding https://github.com/silverstripe/silverstripe-installer/blob/2.4/composer.json#L11
375: [22:48:00] <unsignedint> seems to have worked, thanks!
376: [22:49:00] * osterlaus quit (Quit: Leaving.)
377: [23:37:00] * OldTom has joined #silverstripe
378: [23:49:00] * SticksM has joined #silverstripe
379: [23:53:00] <Pyromanik> fffff compromised
380: [23:57:00] <OldTom> ?

These logs were automatically created by ss-log on irc.freenode.net.